Skip to content
VulniPulse
Advisory severityUnratedApache Software Foundation Updated

Advisory [CVE-2026-108946] Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB

This security Apache Software Foundation advisory covers CVE-2026-108946 affecting Apache ActiveMQ.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-108946 Source published Source updated

VulniPulse record published Record updated

CVE-2026-108946
Affected products & platforms
Apache Software FoundationMessagingActiveMQ
Open source advisory

Get an email when Apache Software Foundation Messaging (ActiveMQ/Kafka/Pulsar) publishes the next one.

See Apache Software Foundation Messaging (ActiveMQ/Kafka/Pulsar)'s last 90 days of advisories first. Then choose the free weekly digest, or a free month of real-time alerts with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Apache Software Foundation Messaging (ActiveMQ/Kafka/Pulsar)

Summary

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.

The ActiveMQ broker resolves connection, session and consumer state from ids that are user provided and in some scenarios does not validate that they ids are bound to that user. This allows an authenticated client to spoof another user's ids.

  • an authenticated client consumes from another connection's temporary queue/topic by putting the victim's connection id in its own ConsumerId, bypassing the broker-side ownership check.
  • a duplicate ConsumerId registration is only logged, after which the attacker's RemoveInfo or disconnect tears down the victim's live subscription
  • a forged MessageAck for the victim's ConsumerId permanently deletes an in-flight, unacknowledged message.

This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.

Users are recommended to upgrade to version 6.4.0, 6.3.3, or 5.19.12, which fixes the issue.

Affected versions
  • 6.0.0 before 6.3.3

Official advisory · medium-confidence parse· fetched 16 hours ago·verify at source

Fixed versions
  • 6.3.3
  • 6.4.0
  • 5.19.12

Official advisory · medium-confidence parse· fetched 16 hours ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 6.4.0, 6.3.3, or 5.19.12, which fixes the issue.

Official advisory · medium-confidence parse· fetched 16 hours ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.