Skip to content
VulniPulse
Advisory severityMedium5.4Apache Software Foundation

Medium [CVE-2026-26032] The PackagerResolver of Apache Ivy is able to download online artifacts and to (re)package them in a format defined by…

This medium-severity Apache Software Foundation advisory covers CVE-2026-26032 affecting Apache Ivy.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-26032 Source published Source updated

VulniPulse record published Record updated

CVE-2026-26032
Affected products & platforms
Apache Software FoundationUnclassified
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

The PackagerResolver of Apache Ivy is able to download online artifacts and to (re)package them in a format defined by a packager.xml file. This repackaging is done by an Ant script, which is stored in a subdirectory of the configured "buildRoot" directory.

This subdirectory is calculated based on modules coordinates, like the organisation, name or version. If one of the coordinates contains "../" sequences - which are valid characters for Ivy coordinates in general- it is possible to break out of the configured "buildRoot" directory where other files can be overwritten.

In order to exploit this vulnerability an attacker needs to have access to a packager repository and add or modify the coordinates in ivy.xml files to have such "../" sequences. Users of Apache Ivy 2.0.0 to 2.5.3 (inclusive) should upgrade to Ivy 2.6.0.

Affected versions
  • Apache Ivy 2.0.0 through 2.5.3

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Fixed versions
  • 2.0.0
  • 2.5.3
  • 2.6.0

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users of Apache Ivy 2.0.0 to 2.5.3 (inclusive) should upgrade to Ivy 2.6.0.

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.