High [CVE-2026-27314] Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator
This high-severity Apache Software Foundation advisory covers CVE-2026-27314 affecting Apache Cassandra.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published
Get an email when Apache Software Foundation publishes the next one.
VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY.
Users are recommended to upgrade to version 5.0.7+, which fixes this issue.
Affected versions
No affected-version range was extracted from the source record. The vendor advisory is authoritative. Check it before change work.
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
Mitigation
Upgrade to a fixed release: 5.0.7. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
More Apache Software Foundation advisories
- CVE-2026-32588Apr 7, 2026Authenticated DoS over CQL in Apache Cassandra 4.0, 4.1, 5.0 allows authenticated user
- CVE-2026-27315Apr 7, 2026Sensitive Information Leak in cqlsh in Apache Cassandra 4.0
- CVE-2026-114349Oct 28, 2026Apache Kafka: When a broker decodes a compressed record batch, the per-record decoder
- CVE-2026-112375Oct 28, 2026Apache Kafka: authenticated Kafka principal with no authorization grants
- CVE-2026-116593Oct 28, 2026Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint
- CVE-2026-115644Oct 28, 2026Apache Kafka Connect contains an authentication bypass vulnerability affecting the admin
Android app · Google Play
Monitor future Apache Software Foundation CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.