High [CVE-2026-31923] Apache APISIX: Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX.
This high-severity Apache Software Foundation advisory covers CVE-2026-31923 affecting Apache APISIX, APISIX.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published
Get an email when Apache Software Foundation publishes the next one.
VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX.
This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0.
Users are recommended to upgrade to version 3.16.0, which fixes the issue.
- 0.7 through 3.15.0.
- through 3.15.0
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
- 3.16.0
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
Mitigation
Upgrade to a fixed release: 3.16.0. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
More Apache Software Foundation advisories
- CVE-2026-31924Apr 14, 2026Apache APISIX: Cleartext Transmission of Sensitive Information vulnerability in Apache
- CVE-2026-31908Apr 14, 2026Apache APISIX: Header injection vulnerability in Apache APISIX.
- CVE-2026-94276Oct 1, 2026Apache APISIX authentication bypass
- CVE-2026-94269Oct 1, 2026Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX
- CVE-2026-94250Oct 1, 2026Allocation of resources without limits or throttling vulnerability in batch-requests
- CVE-2026-94220Oct 1, 2026Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins
Android app · Google Play
Monitor future Apache Software Foundation CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.