Skip to content
VulniPulse
Advisory severityMedium4.3Apache Software Foundation

Medium [CVE-2026-33227] Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker…

This medium-severity Apache Software Foundation advisory covers CVE-2026-33227 affecting Apache ActiveMQ, Apache ActiveMQ Client, Apache ActiveMQ Broker.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-33227 Source published Source updated

VulniPulse record published

CVE-2026-33227
Affected products & platforms
Apache Software FoundationMessagingActiveMQ
Open source advisory

Summary

Improper validation and restriction of a classpath path name vulnerability in

Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ.

In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation.

As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit.

Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.

Is CVE-2026-33227 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-33227 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-33227?

Upgrade to a fixed release named by Apache:

  • 5.19.4
  • 6.2.3
  • 5.19.3
  • 6.2.2

Confirm against the vendor advisory before you patch.

Affected versions
  • 6.0.0 through 6.2.2
  • 6.0.0 through 6.2.2.

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Fixed versions
  • 5.19.4
  • 6.2.3
  • 5.19.3
  • 6.2.2

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Mitigation

Upgrade to a fixed release: 5.19.4, 6.2.3, 5.19.3, 6.2.2. That is the remediation for this advisory.

The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Get an email when Apache Messaging (ActiveMQ/Kafka/Pulsar) publishes the next one.

See Apache Messaging (ActiveMQ/Kafka/Pulsar)'s last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Apache Messaging (ActiveMQ/Kafka/Pulsar)
All Apache Software Foundation advisories

iPhone and Android apps · New on the App Store

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.