Skip to content
VulniPulse
Advisory severityCritical9.1Apache Software Foundation

Critical [CVE-2026-59084] Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the…

This critical-severity Apache Software Foundation advisory covers CVE-2026-59084 affecting Apache Tomcat.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-59084 Source published Source updated

VulniPulse record published Record updated

Affected products & platforms
Apache Software FoundationTomcat
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.

Affected versions
  • 11.0.0-M1 through 11.0.23
  • 10.1.0-M1 through 10.1.56
  • 9.0.13 through 9.0.119
  • 8.5.38 through 8.5.100
  • 7.0.100 through 7.0.109.
  • through 7.0.109

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Fixed versions
  • 11.0.24
  • 10.1.57
  • 9.0.120

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented.
  • Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.

Official advisory · high-confidence parse· fetched 4 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.