Medium [CVE-2026-59230] Improper input validation vulnerability in Apache Camel
This medium-severity Apache Software Foundation advisory covers CVE-2026-59230 affecting Apache Camel.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Apache Software Foundation publishes the next one.
VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
Improper input validation vulnerability in Apache Camel.
This issue affects Apache Camel: from 2.17.0 before 4.14.9, from 4.15.0 before 4.18.4, from 4.19.0 before 4.22.0.
The camel-mail component ships a MimeMultipart data format that can unmarshal a MIME multipart message.
When it is configured with headersInline set to true, the unmarshal path copies the MIME headers of the incoming message onto the Camel message: it enumerates every header that is not one of the three standard ones it generates itself - Message-ID, MIME-Version and Content-Type - and calls setHeader for each, applying no HeaderFilterStrategy.
The names of those MIME headers come from the message being unmarshalled, so a sender able to influence the message could place a header whose name falls in the Camel-internal namespace and have it set on the Exchange.
Camel components read control headers from that namespace to override their configured behaviour - the camel-sql producer, for instance, takes the statement to execute from a Camel header when one is present - so an injected header could redirect what a downstream step in the route does with data the route author never intended it to take from the message.
Which sinks are reachable, and what the consequences are, depends entirely on what the route does after the unmarshal step.
- 2.17.0 before 4.14.9
- 4.15.0 before 4.18.4
- 4.19.0 before 4.22.0
Official advisory · high-confidence parse· fetched 2 months ago·verify at source
- 4.14.9
- 4.18.4
- 4.22.0
Official advisory · high-confidence parse· fetched 2 months ago·verify at source
Mitigation checklist
- Users are recommended to upgrade to version 4.22.0, which fixes the issue.
- If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.9.
- If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.4.
- For deployments that cannot upgrade immediately, leave headersInline at its default of false where the inline headers are not needed, since the copy is only reached when it is enabled.
Official advisory · high-confidence parse· fetched 2 months ago·verify at source
More Apache Software Foundation advisories
- CVE-2026-91858Oct 19, 2026FopProducer transforms the incoming XSL-FO message body by creating
- CVE-2026-88901Oct 19, 2026Apache Camel XXE
- CVE-2026-85315Oct 19, 2026Generation of Error Message Containing Sensitive Information vulnerability in Apache Camel
- CVE-2026-83531Oct 19, 2026Apache Camel expression language injection
- CVE-2026-78162Oct 19, 2026Deserialization of Untrusted Data vulnerability in Apache Camel
- CVE-2026-80354Sep 10, 2026Authorization bypass through User-Controlled key vulnerability in Apache Camel K
Android app · Google Play
Monitor future Apache Software Foundation CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.