Skip to content
VulniPulse
Advisory severityHigh7.5Apache Software Foundation

High [CVE-2026-59878] Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All

This high-severity Apache Software Foundation advisory covers CVE-2026-59878 affecting Apache ActiveMQ AMQP, Apache ActiveMQ All.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-59878 Source published Source updated

VulniPulse record published Record updated

CVE-2026-59878
Affected products & platforms
Apache Software FoundationMessagingActiveMQ
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All.

A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections.

This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8.

Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.

Affected versions
  • 6.0.0 through 6.2.8
  • 6.0.0 through 6.2.8.

Official advisory · high-confidence parse· fetched 3 months ago·verify at source

Fixed versions
  • 5.19.9
  • 6.2.8
  • 6.3.0

Official advisory · high-confidence parse· fetched 3 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.

Official advisory · high-confidence parse· fetched 3 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.