Skip to content
VulniPulse
Advisory severityMedium6.8Apache Software Foundation

Medium [CVE-2026-73180] Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended

This medium-severity Apache Software Foundation advisory covers CVE-2026-73180 affecting Apache Tomcat.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-73180 Source published Source updated

VulniPulse record published Record updated

Affected products & platforms
Apache Software FoundationTomcat
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109.

Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected versions
  • 11.0.0-M1 through 11.0.24
  • 10.1.0-M1 through 10.1.57
  • 9.0.0.M1 through 9.0.120.
  • 8.5.0 through 8.5.100
  • 7.0.43 through 7.0.109.
  • through 9.0.120
  • through 7.0.109

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Fixed versions
  • 11.0.25
  • 10.1.58
  • 9.0.121

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.