Skip to content
VulniPulse
Advisory severityHigh8.8Apache Software Foundation Updated

High [CVE-2026-82910] Improper Neutralization of Special Elements Used in a Template Engine ('Server-Side Template Injection') in MacroScreenRenderer in Apache OFBiz 24.09 before 24.09.08 on all platforms allows a remote authenticated attacker holding only the two view permissions of a control-servlet webapp (e.g

This high-severity Apache Software Foundation advisory covers CVE-2026-82910 affecting Apache OFBiz.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-82910 Source published Source updated

VulniPulse record published Record updated

CVE-2026-82910
Affected products & platforms
Apache Software FoundationOFBiz
Open source advisory

Summary

Improper Neutralization of Special Elements Used in a Template Engine ('Server-Side Template Injection') in MacroScreenRenderer in Apache OFBiz 24.09 before 24.09.08 on all platforms allows a remote authenticated attacker holding only the two view permissions of a control-servlet webapp (e.g.

CATALOG_VIEW and OFBTOOLS_VIEW on /catalog, held by OFBiz's own shipped order-entry clerk role) to execute arbitrary operating system commands as the OFBiz service account with a single GET request, by placing an apostrophe followed by FreeMarker expression source in a screen link parameter value, because renderLink concatenates link parameter values verbatim between apostrophes into an unquoted, unescaped template-source string that is compiled and evaluated at render time, allowing the injected expression to reach the allow-listed FlexibleStringExpander.expandString call and, through a runtime-assembled Groovy interpolation, unsandboxed code execution.

Users are recommended to upgrade to version 24.09.08, which fixes this issue.

Is CVE-2026-82910 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-82910 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-82910?

Upgrade to a fixed release named by Apache:

  • 24.09.08

Confirm against the vendor advisory before you patch.

Affected versions
  • 24.09

Official advisory · high-confidence parse· fetched 3 days ago·verify at source

Fixed versions
  • 24.09.08

Official advisory · high-confidence parse· fetched 3 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 24.09.08, which fixes this issue.

Official advisory · high-confidence parse· fetched 3 days ago·verify at source

Get an email when Apache publishes the next one.

See Apache's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Apache
All Apache Software Foundation advisories

iPhone and Android apps · New on the App Store

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.