Medium [CVE-2026-85301] Improper Authentication vulnerability in Apache Camel Keycloak component
This medium-severity Apache Software Foundation advisory covers CVE-2026-85301 affecting Apache Camel Keycloak.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Apache Software Foundation publishes the next one.
VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
Improper Authentication vulnerability in Apache Camel Keycloak component.
This issue affects Apache Camel: from 4.15.0 before 4.18.5, from 4.19.0 before 4.22.1.
The security processor validated the issuer of an introspected token only when the introspection response actually carried an iss claim. When the claim was absent the check was skipped rather than treated as a failure, so a token that the configured issuer did not mint could be accepted provided the introspection endpoint answered without naming an issuer.
Reaching this requires an introspection endpoint that omits iss and accepts tokens from more than one issuer, which is not the default Keycloak arrangement, hence the low severity; where that arrangement exists the consequence is that the deployment authenticates a caller it should have rejected.
Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5.
An absent iss claim is now treated as a validation failure rather than as a reason to skip the check. For deployments that cannot upgrade immediately, ensure the introspection endpoint returns the iss claim, and that it serves exactly one issuer.
- 4.15.0 before 4.18.5
- 4.19.0 before 4.22.1
Official advisory · high-confidence parse· fetched 9 days ago·verify at source
- 4.18.5
- 4.22.1
Official advisory · high-confidence parse· fetched 9 days ago·verify at source
Mitigation checklist
- Upgrade to Apache Camel 4.23.0, which fixes the issue.
- Users on the 4.18.x LTS releases stream should upgrade to 4.18.5.
- Users on the 4.22.x LTS releases stream should upgrade to 4.22.1.
- For deployments that cannot upgrade immediately, ensure the introspection endpoint returns the iss claim, and that it serves exactly one issuer.
Official advisory · high-confidence parse· fetched 9 days ago·verify at source
More Apache Software Foundation advisories
- CVE-2026-95663Oct 26, 2026Insufficient Session Expiration vulnerability in Apache Camel Keycloak component
- CVE-2026-53913Jul 6, 2026Apache Camel: Improper Authentication, Missing Authentication for Critical Function, Not
- CVE-2026-46455Jul 6, 2026Insufficient Session Expiration vulnerability in Apache Camel Keycloak Component
- CVE-2026-111422Oct 26, 2026Apache Airflow SSH provider command injection
- CVE-2026-115748Oct 26, 2026**UNSUPPORTED WHEN ASSIGNED** Authorization bypass in Apache Vysper, all versions
- CVE-2026-115721Oct 26, 2026**UNSUPPORTED WHEN ASSIGNED** Unbounded allocation in XML parsing in Apache Vysper; all
Android app · Google Play
Monitor future Apache Software Foundation CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.