Skip to content
VulniPulse
Advisory severityLow2.3Apache Software Foundation Updated

Low [CVE-2026-87718] Apache Wicket 10.10.0, 10.11.0 and 9.24.0 do not set the Content-Security-Policy headers on a page whose render request handler is wrapped in more than one IRequestHandlerDelegate

This low-severity Apache Software Foundation advisory covers CVE-2026-87718; related products: Apache Wicket.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-87718 Source published Source updated

VulniPulse record published Record updated

CVE-2026-87718
Related products & platforms
Apache Software FoundationUnclassified
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

See Apache Software Foundation's last 90 days of advisories first. Then choose the free weekly digest, or a free month of real-time alerts with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Apache Software Foundation

Summary

Apache Wicket 10.10.0, 10.11.0 and 9.24.0 do not set the Content-Security-Policy headers on a page whose render request handler is wrapped in more than one IRequestHandlerDelegate.

The framework unwraps only a single delegate level when deciding whether a request renders a page, so with a deeper chain, for example an application-provided delegating request mapper combined with CryptoMapper, the page is served without any CSP header even though CSP is enabled, and no error or warning is raised.

The nonce-based protection Wicket applies to inline scripts and styles, together with any other CSP directives configured by the application, is thereby lost for those pages, exposing them to content injection the policy was meant to prevent. Applications on stock Wicket that do not wrap request handlers themselves are not affected.

Versions before 10.10.0 and 9.24.0 handled nested delegates correctly. Users are recommended to upgrade to version 10.12.0 or 9.25.0, which fix the issue.

Affected versions
  • 9.24.0

Official advisory · high-confidence parse· fetched 6 hours ago·verify at source

Fixed versions
  • 10.12.0
  • 9.25.0
  • 10.10.0

Official advisory · high-confidence parse· fetched 6 hours ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 10.12.0 or 9.25.0, which fix the issue.

Official advisory · high-confidence parse· fetched 6 hours ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.