High [CVE-2026-20293] Cisco UCS and UCS-Based Appliances UEFI Shell Secure Boot Bypass Vulnerability
This high-severity Cisco advisory covers CVE-2026-20293 affecting Unified Computing System E-Series Software (UCSE), Unified Computing System (Managed), Unified Computing System (Standalone).
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Cisco publishes the next one.
VulniPulse checks Cisco's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
A vulnerability in the Unified Extensible Firmware Interface (UEFI) Shell implementation of Cisco UCS Servers and UCS-based appliances could allow an authenticated attacker with valid credentials for a user account with the role of user or admin or an unauthenticated attacker with physical access to an affected device to bypass UEFI Secure Boot validation checks and execute unauthorized software.
This vulnerability is due to the availability of memory write commands in the UEFI Shell while UEFI Secure Boot is enabled on a device. An attacker could exploit this vulnerability by selecting the UEFI Shell boot option at boot time and using available shell commands to modify UEFI memory variables.
A successful exploit could allow the attacker to manipulate the preboot environment, overwrite UEFI Secure Boot-related memory values, and execute unauthorized software on the affected device.
Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.
Affected products named by the advisory: Unified Computing System E-Series Software (UCSE); Unified Computing System (Managed); Unified Computing System (Standalone); Enterprise NFV Infrastructure Software.
- Scope: This vulnerability affects the following Cisco products if they have UEFI Secure Boot enabled and are running a vulnerable BIOS version:
- Earlier than 4.12 — Migrate to a fixed release
- Release 4.12 (first fixed: 4.12.9 (Jan 2027))
- 4.13 — Migrate to a fixed release
- 4.14 — Migrate to a fixed release
- Release 4.15 (first fixed: 4.15.7 (Nov 2026))
- Earlier than 4.3 — Migrate to a fixed release
- Release 4.3 (first fixed: 4.3(6k))
- Release 6.0 (first fixed: 6.0(2e))
- Release 4.3 (first fixed: 4.3(6h))
- Release 6.0 (first fixed: 6.0(2d))
- Earlier than 5.4 — Migrate to a fixed release
- Release 5.4 (first fixed: Release no. TBD (Nov 2026))
- Release 6.0 (first fixed: 6.0(1.260031))
- Release 5.4 (first fixed: 5.4(0.260050))
- Release 6.0 (first fixed: 6.0(2.260143))
- Release 5.4 (first fixed: 5.4(0.260042))
- Release 2.0 (first fixed: Release no. TBD (Oct 2026))
- Release 4.0 (first fixed: 4.0(2.260004))
- Release 1.2 and earlier (first fixed: Release no. TBD (Oct 2026))
Official advisory · high-confidence parse· fetched 16 days ago·verify at source
- 4.12.9 (Jan 2027)
- 4.15.7 (Nov 2026)
- 4.3(6k)
- 6.0(2e)
- 4.3(6h)
- 6.0(2d)
- Release no. TBD (Nov 2026)
- 6.0(1.260031)
- 5.4(0.260050)
- 6.0(2.260143)
- 5.4(0.260042)
- Release no. TBD (Oct 2026)
- 4.0(2.260004)
Official advisory · high-confidence parse· fetched 16 days ago·verify at source
Mitigation checklist
- Upgrade to the first fixed release for your train per the Fixed Releases table in this advisory.
- Earlier than 4.12: migrate to a fixed release.
- Release 4.12: upgrade to 4.12.9 (Jan 2027).
- Release 4.13: migrate to a fixed release.
- Release 4.14: migrate to a fixed release.
- Release 4.15: upgrade to 4.15.7 (Nov 2026).
- Earlier than 4.3: migrate to a fixed release.
- Release 4.3: upgrade to 4.3(6k).
- Release 6.0: upgrade to 6.0(2e).
- There are no workarounds that address this vulnerability.
Official advisory · high-confidence parse· fetched 16 days ago·verify at source
More Cisco advisories
- CVE-2026-20200Aug 5, 2026Cisco Integrated Management Controller Argument Injection Vulnerabilities
- CVE-2026-20198Aug 5, 2026Cisco Integrated Management Controller Cross-Site Scripting Vulnerability
- CVE-2026-20085Apr 22, 2026Cisco Integrated Management Controller Cross-Site Scripting Vulnerabilities
- CVE-2026-20094Apr 22, 2026Cisco Integrated Management Controller Command Injection and Remote Code Execution
- CVE-2026-20093Apr 1, 2026Cisco Integrated Management Controller Authentication Bypass Vulnerability
- CVE-2026-76471Oct 7, 2026Cisco NX-OS Software NX-API Remote Code Execution Vulnerability
Android app · Google Play
Monitor future Cisco CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.