High [CVE-2026-56434] NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module
This high-severity F5 advisory covers CVE-2026-56434 affecting NGINX Plus, NGINX Open Source.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when F5 publishes the next one.
VulniPulse checks F5's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssi_module module. This vulnerability may exist when the Server-Side Includes (SSI), proxy_pass, and proxy_buffering off directives are configured.
With this configuration, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to cause a use-after-free in the NGINX worker process. This issue may lead to limited modification of memory or a restart of the NGINX worker process.
Impact: There is no control plane exposure; this is a data plane issue only.
Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
- NGINX Plus 37.0.0.1 before 37.0.3.1
- NGINX Plus R36 before R36 P7
- NGINX Plus R33
- NGINX Open Source 1.31.2 before 1.31.3
- NGINX Open Source 0.8.11 before 1.30.4
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
- 37.0.3.1
- R36 P7
- 1.31.3
- 1.30.4
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
Mitigation
Upgrade to a fixed release: 37.0.3.1, R36 P7, 1.31.3, 1.30.4. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 4 months ago·verify at source
More F5 advisories
- CVE-2026-95101Oct 14, 2026Description NGINX Plus and NGINX Open Source have a vulnerability
- CVE-2026-97205Oct 14, 2026NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module
- CVE-2026-93479Oct 14, 2026vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex
- CVE-2026-97629Oct 14, 2026Description When NGINX Plus or NGINX Open Source is configured with ssl_session_cache
- CVE-2026-15176Oct 14, 2026vulnerability exists in NGINX Plus and NGINX Open Source when a location is configured
- CVE-2026-90439Sep 15, 2026NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module
Android app · Google Play
Monitor future F5 CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.