Skip to content
VulniPulse
Advisory severityMedium5.9Red Hat Linux

Medium [CVE-2026-48815] Unauthorized certificates accepted due to ignored `certificateOIDs` verification option

This medium-severity Red Hat Linux advisory covers CVE-2026-48815 affecting Exploit Intelligence, Red Hat Connectivity Link 1, Red Hat Enterprise Linux 10.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-48815 Source published Source updated

VulniPulse record published Record updated

CVE-2026-48815
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

sigstore-js provides JavaScript libraries for interacting with Sigstore services.

Prior to 4.1.1, the documented certificateOIDs option in sigstore.verify() is accepted by the public API but discarded before verification, so required certificate extension OIDs are never checked and applications relying on certificateOIDs to restrict which certificates may sign artifacts can accept unauthorized certificates.

This issue is fixed in version 4.1.1. A flaw was found in sigstore.

This allows unauthorized certificates to be accepted, bypassing security policies that rely on specific certificate extension object identifiers (OIDs). As a result, applications that depend on this option for security receive no protection, potentially leading to the acceptance of malicious or untrusted artifacts.

Note: The CVSS has been adjusted with AC:H, due to it's low real-world exposure. Red Hat severity: Moderate — CVSS 5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N).

Weakness: CWE-345. Affected Red Hat products: Exploit Intelligence; Red Hat Connectivity Link 1; Red Hat Enterprise Linux 10; Red Hat Enterprise Linux 8; Red Hat Enterprise Linux 9; Red Hat Enterprise Linux AI (RHEL AI) 3.

Will not fix / out of support: Red Hat Connectivity Link 1. Red Hat does not currently list a fixing RHSA for this CVE.

Is CVE-2026-48815 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-48815 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-48815?

Upgrade to a fixed release named by Red Hat:

  • 4.1.1

Confirm against the vendor advisory before you patch.

Affected versions
  • < 4.1.1

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Fixed versions
  • 4.1.1

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.