Skip to content
VulniPulse
Advisory severityMedium6.5Red Hat Linux

Medium [CVE-2026-48816] Insufficient verification of data authenticity allows timestamp manipulation

This medium-severity Red Hat Linux advisory covers CVE-2026-48816 affecting Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-48816 Source published Source updated

VulniPulse record published Record updated

CVE-2026-48816
Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Summary

sigstore-js provides JavaScript libraries for interacting with Sigstore services.

Prior to 3.1.1, @sigstore/verify derives a transparency-log timestamp from tlogEntries[].integratedTime for bundle v0.2 inclusionProof-only entries even though the inclusion proof path does not cryptographically bind integratedTime, allowing an attacker who can supply an untrusted bundle to influence certificate validity and timestampThreshold verification decisions.

This issue is fixed in version 3.1.1. A flaw was found in sigstore-js.

This could lead to incorrect validation of certificate validity. Red Hat severity: Moderate — CVSS 6.5 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N).

Weakness: CWE-345. Affected Red Hat products: Red Hat Enterprise Linux 10; Red Hat Enterprise Linux 8; Red Hat Enterprise Linux 9; Red Hat OpenShift Dev Spaces; Red Hat Satellite 6; Self-service automation portal 2.

Red Hat does not currently list a fixing RHSA for this CVE.

Affected products named by the advisory: Red Hat package: sigstore.

Is CVE-2026-48816 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-48816 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-48816?

Upgrade to a fixed release named by Red Hat:

  • 3.1.1

Confirm against the vendor advisory before you patch.

Affected versions
  • < 3.1.1

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Fixed versions
  • 3.1.1

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Upgrade to the latest sigstore-js (>= 3.1.1) release that addresses GHSA-xgjw-pm74-86q4.

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Get an email when Red Hat RHEL & SELinux publishes the next one.

See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat RHEL & SELinux
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.