Skip to content
VulniPulse
Advisory severityMedium5.9Vendor: HighRed Hat Linux

Medium [CVE-2026-49476] Denial of Service via crafted CSS selector string

This medium-severity Red Hat Linux advisory covers CVE-2026-49476 affecting Red Hat Hardened Images, Red Hat OpenShift AI 3.4, Exploit Intelligence.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-49476 Source published Source updated

VulniPulse record published Record updated

CVE-2026-49476
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4.

Prior to 2.8.4, the CSS selector parser in soupsieve allocates unbounded memory when compiling large comma-separated selector lists, allowing an attacker who can supply a crafted selector string to soupsieve.compile() or Beautiful Soup.select() /.select_one() to allocate hundreds of megabytes of heap memory from a relatively small input and cause denial of service.

This issue is fixed in version 2.8.4. An uncontrolled resource consumption vulnerability was found in the soupsieve Python package, a CSS selector library used by BeautifulSoup4.

A remote attacker could provide a crafted CSS selector string that causes excessive memory or CPU consumption, leading to a denial of service condition. It requires the application to accept untrusted CSS selectors supplied in one of the following sinks: * soupsieve.compile() * BeautifulSoup.select() * BeautifulSoup.select_one() This is an uncommon scenario.

Red Hat severity: Important — CVSS 5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H). Weakness: CWE-770.

Affected products named by the advisory: Red Hat Hardened Images; Red Hat OpenShift AI 3.4; Exploit Intelligence; Lightspeed Core; and 9 more.

Is CVE-2026-49476 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-49476 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-49476?

Upgrade to a fixed release named by Red Hat:

  • 2.8.4
  • python-rpds-py-main-2026.6.3-1.hum1
  • rhoai/odh-pipeline-runtime-datascience-cpu-py312-rhel9:1787073866
  • rhoai/odh-pipeline-runtime-minimal-cpu-py312-rhel9:1787073936
  • rhoai/odh-pipeline-runtime-pytorch-cuda-py312-rhel9:1787073873
  • rhoai/odh-pipeline-runtime-pytorch-llmcompressor-cuda-py312-rhel9:1787073459
  • rhoai/odh-pipeline-runtime-pytorch-rocm-py312-rhel9:1787073611
  • rhoai/odh-pipeline-runtime-tensorflow-cuda-py312-rhel9:1787073451
  • rhoai/odh-pipeline-runtime-tensorflow-rocm-py312-rhel9:1787073451
  • rhoai/odh-th06-cpu-torch210-py312-rhel9:1787076778
  • rhoai/odh-th06-cuda130-torch210-py312-rhel9:1787077779
  • rhoai/odh-th06-rocm64-torch291-py312-rhel9:1787076481

11 more fixed releases are listed below.

Confirm against the vendor advisory before you patch.

Affected versions
  • < 2.8.4

Official advisory · high-confidence parse· fetched 6 days ago·verify at source

Fixed versions
  • 2.8.4
  • python-rpds-py-main-2026.6.3-1.hum1
  • rhoai/odh-pipeline-runtime-datascience-cpu-py312-rhel9:1787073866
  • rhoai/odh-pipeline-runtime-minimal-cpu-py312-rhel9:1787073936
  • rhoai/odh-pipeline-runtime-pytorch-cuda-py312-rhel9:1787073873
  • rhoai/odh-pipeline-runtime-pytorch-llmcompressor-cuda-py312-rhel9:1787073459
  • rhoai/odh-pipeline-runtime-pytorch-rocm-py312-rhel9:1787073611
  • rhoai/odh-pipeline-runtime-tensorflow-cuda-py312-rhel9:1787073451
  • rhoai/odh-pipeline-runtime-tensorflow-rocm-py312-rhel9:1787073451
  • rhoai/odh-th06-cpu-torch210-py312-rhel9:1787076778
  • rhoai/odh-th06-cuda130-torch210-py312-rhel9:1787077779
  • rhoai/odh-th06-rocm64-torch291-py312-rhel9:1787076481
  • rhoai/odh-workbench-jupyter-datascience-cpu-py312-rhel9:1787074331
  • rhoai/odh-workbench-jupyter-minimal-cpu-py312-rhel9:1787073913
  • rhoai/odh-workbench-jupyter-minimal-cuda-py312-rhel9:1787074078
  • rhoai/odh-workbench-jupyter-minimal-rocm-py312-rhel9:1787073929
  • rhoai/odh-workbench-jupyter-pytorch-cuda-py312-rhel9:1787073605
  • rhoai/odh-workbench-jupyter-pytorch-rocm-py312-rhel9:1787073546
  • rhoai/odh-workbench-jupyter-tensorflow-cuda-py312-rhel9:1787073717
  • rhoai/odh-workbench-jupyter-tensorflow-rocm-py312-rhel9:1787073713
  • rhoai/odh-workbench-jupyter-trustyai-cpu-py312-rhel9:1787073593
  • RHSA-2026:34119
  • RHSA-2026:60520

Official advisory · high-confidence parse· fetched 6 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • There is no mitigation for this flaw other than updating the soupsieve package when upstream patches are available. The impact is limited to availability (denial of service) — an attacker cannot access or modify data through this vulnerability. Applications that do not process untrusted CSS selector strings are at reduced risk.

Official advisory · high-confidence parse· fetched 6 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.