Skip to content
VulniPulse
Advisory severityMedium5.8Red Hat Linux

Medium [CVE-2026-52761] Web Application Firewall rules bypass due to incorrect UTF-8 to Unicode transformation

This medium-severity Red Hat Linux advisory covers CVE-2026-52761 affecting Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-52761 Source published Source updated

VulniPulse record published Record updated

CVE-2026-52761
Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Summary

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx.

From 3.0.0 through 3.0.15, the t:utf8toUnicode transformation in src/actions/transformations/utf8_to_unicode.cc produces wrong output on i386 architecture because snprintf uses sizeof on a char pointer rather than the length of the unicode buffer, allowing rules that use this transformation to be bypassed on i386 architecture.

This issue is fixed in version 3.0.16. The `t:utf8toUnicode` transformation function, responsible for converting UTF-8 encoded characters to Unicode, generates incorrect output on i386 architectures.

This vulnerability allows an attacker to bypass WAF rules, potentially enabling malicious requests to reach the protected application. The consequence is a moderate integrity loss due to the circumvention of security controls.

Conditions for Exploitation: Exploitation is strictly limited to 32-bit (i386) architectures, which reduces the likelihood of exploitation in typical deployments. Furthermore, it requires the ModSecurity configuration to actively use rules that rely on the affected transformation function.

Impact Limitations: The vulnerability functions solely as a WAF rule bypass and does not directly cause privilege escalation, data corruption, or arbitrary code execution on the host system.

Is CVE-2026-52761 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-52761 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-52761?

Upgrade to a fixed release named by Red Hat:

  • 3.0.16

Confirm against the vendor advisory before you patch.

Affected versions
  • 3.0.0
  • 3.0.15

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Fixed versions
  • 3.0.16

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Get an email when Red Hat RHEL & SELinux publishes the next one.

See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat RHEL & SELinux
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.