Medium [CVE-2026-53432] Denial of Service via Integer Overflow in FuzzyMatchV2 function
This medium-severity Red Hat Linux advisory covers CVE-2026-53432.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
fzf is vulnerable to Integer Overflow leading to crash in FuzzyMatchV2 function. When input line length is approximately 2,200,000 bytes and pattern length is 999 bytes, the product overflows.
The Go runtime detects the invalid slice bounds and terminates the process immediately with a non-recoverable panic. This issue was fixed in version 0.73.1.
A flaw was found in fzf. An integer overflow vulnerability exists in the FuzzyMatchV2 function when processing exceptionally long input lines and patterns.
This can lead to the application terminating unexpectedly with a non-recoverable panic, resulting in a Denial of Service (DoS). A local user could exploit this by providing specially crafted input.
An integer overflow in the FuzzyMatchV2 function can cause a non-recoverable Go runtime panic when processing a specially crafted input of approximately 2.2 million bytes with a 999-byte pattern. Exploitation requires local access and user interaction — an attacker must supply the crafted input to a running fzf process.
Red Hat severity: Moderate — CVSS 5 (CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H). Weakness: CWE-190.
Is CVE-2026-53432 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-53432 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-53432?
Upgrade to a fixed release named by Red Hat:
- 0.73.1
Confirm against the vendor advisory before you patch.
Affected versions
No affected-version range was extracted from the source record. The vendor advisory is authoritative. Check it before change work.
Official advisory · high-confidence parse· fetched 12 days ago·verify at source
Mitigation checklist
- No mitigation is available for this vulnerability. The panic is non-recoverable once triggered. Users should upgrade to fzf 0.73.1 or later.
Official advisory · high-confidence parse· fetched 12 days ago·verify at source
Get an email when Red Hat publishes the next one.
See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.