Skip to content
VulniPulse
Advisory severityMedium5.9Red Hat Linux

Medium [CVE-2026-54291] Man-in-the-middle protection bypass via SCRAM-SHA-256-PLUS downgrade

This medium-severity Red Hat Linux advisory covers CVE-2026-54291 affecting Red Hat build of Keycloak 26.4.15, Red Hat build of Keycloak 26.6.6, Red Hat build of Quarkus 3.27.5.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-54291 Source published Source updated

VulniPulse record published Record updated

CVE-2026-54291
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

pgjdbc is an open source postgresql JDBC Driver. In releases 42.7.4 through 42.7.11, channelBinding=require connections can be silently downgraded from SCRAM-SHA-256-PLUS with channel binding to plain SCRAM-SHA-256 without it, losing the man-in-the-middle protection the setting is meant to guarantee.

An attacker who can intercept the TLS connection can trigger the downgrade with a certificate whose signature algorithm has no tls-server-end-point channel-binding hash, because the bundled com.ongres.scram:scram-client returns an empty byte array instead of failing and pgJDBC ScramAuthenticator checks only that the server advertised a PLUS mechanism, without rejecting the empty binding or checking that the negotiated mechanism uses channel binding.

This issue is fixed in version 42.7.12. A remote attacker who can intercept a TLS (Transport Layer Security) connection can silently downgrade connections configured to require channel binding from SCRAM-SHA-256-PLUS to plain SCRAM-SHA-256.

This downgrade bypasses the intended man-in-the-middle protection, allowing the attacker to potentially intercept or alter sensitive communication. The vulnerability occurs because the system fails to properly validate the channel binding when a specific type of certificate is used.

Red Hat severity: Moderate — CVSS 5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N). Weakness: CWE-940.

Is CVE-2026-54291 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-54291 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-54291?

Upgrade to a fixed release named by Red Hat:

  • 42.7.12
  • 3.3
  • postgresql
  • RHSA-2026:56520
  • RHSA-2026:56523
  • RHSA-2026:53643
  • RHSA-2026:51653

Confirm against the vendor advisory before you patch.

Affected versions
  • 42.7.4
  • 42.7.11

Official advisory · high-confidence parse· fetched 10 days ago·verify at source

Fixed versions
  • 42.7.12
  • 3.3
  • postgresql
  • RHSA-2026:56520
  • RHSA-2026:56523
  • RHSA-2026:53643
  • RHSA-2026:51653

Official advisory · high-confidence parse· fetched 10 days ago·verify at source

Mitigation

Upgrade to a fixed release: 42.7.12, 3.3, postgresql, RHSA-2026:56520, RHSA-2026:56523, RHSA-2026:53643. That is the remediation for this advisory.

The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.

Official advisory · high-confidence parse· fetched 10 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.