Skip to content
VulniPulse
Advisory severityHigh7.5Red Hat Linux

High [CVE-2026-55574] Denial of Service via adversarial regular expression in structured outputs API

This high-severity Red Hat Linux advisory covers CVE-2026-55574 affecting Red Hat AI Inference Server 3.2, Red Hat AI Inference Server 3.3, Red Hat AI Inference Server 3.4.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-55574 Source published Source updated

VulniPulse record published Record updated

CVE-2026-55574
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs.

Prior to 0.24.0, the structured_outputs.regex API parameter passes a user-supplied regular expression string directly to the grammar compiler backends with no compilation timeout; in the xgrammar backend the string reaches the regex compiler with no guard, and in the outlines backend the validation step blocks structural issues such as lookarounds and backreferences but performs no complexity analysis, so a pattern with nested quantifiers passes all checks and causes exponential state-space expansion, allowing a single request containing an adversarial regex to hang an inference worker indefinitely and deny service.

This issue is fixed in version 0.24.0. A remote attacker could exploit this vulnerability by providing a specially crafted regular expression to the structured_outputs.regex API parameter.

This results in a Denial of Service (DoS) for the affected system. An Important denial of service vulnerability exists in vLLM, as utilized within Red Hat AI Inference Server and Red Hat OpenShift AI.

Red Hat severity: Important — CVSS 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H). Weakness: CWE-1333.

Affected products named by the advisory: Red Hat AI Inference Server 3.2; Red Hat AI Inference Server 3.3; Red Hat AI Inference Server 3.4; Red Hat Enterprise Linux AI 3.4; and 2 more.

Is CVE-2026-55574 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-55574 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-55574?

Upgrade to a fixed release named by Red Hat:

  • 0.24.0
  • rhaiis/vllm-cuda-rhel9:1787860580
  • rhaiis/vllm-rocm-rhel9:1787884873
  • rhaiis/vllm-spyre-rhel9:1787161776
  • rhaii/vllm-spyre-rhel9:1789681201
  • rhaii/vllm-cpu-rhel9:1789681128
  • rhaii/vllm-cuda-rhel9:1789681126
  • rhaii/vllm-rocm-rhel9:1789681126
  • rhaii/vllm-cpu-rhel9:1790075793
  • rhaii/vllm-spyre-rhel9:1790076141
  • rhaii/vllm-cuda-rhel9:1790090131
  • rhaii/vllm-rocm-rhel9:1790109620

20 more fixed releases are listed below.

Confirm against the vendor advisory before you patch.

Affected versions
  • < 0.24.0

Official advisory · high-confidence parse· fetched 14 days ago·verify at source

Fixed versions
  • 0.24.0
  • rhaiis/vllm-cuda-rhel9:1787860580
  • rhaiis/vllm-rocm-rhel9:1787884873
  • rhaiis/vllm-spyre-rhel9:1787161776
  • rhaii/vllm-spyre-rhel9:1789681201
  • rhaii/vllm-cpu-rhel9:1789681128
  • rhaii/vllm-cuda-rhel9:1789681126
  • rhaii/vllm-rocm-rhel9:1789681126
  • rhaii/vllm-cpu-rhel9:1790075793
  • rhaii/vllm-spyre-rhel9:1790076141
  • rhaii/vllm-cuda-rhel9:1790090131
  • rhaii/vllm-rocm-rhel9:1790109620
  • rhelai3/disk-image-cuda-rhel9:1790957417
  • rhelai3/bootc-aws-cuda-rhel9:1790881122
  • rhelai3/bootc-azure-cuda-rhel9:1790881120
  • rhelai3/bootc-azure-rocm-rhel9:1790707552
  • rhelai3/bootc-cuda-rhel9:1790868254
  • rhelai3/bootc-gcp-cuda-rhel9:1790881123
  • rhelai3/bootc-rocm-rhel9:1790614447
  • RHSA-2026:61627
  • RHSA-2026:61629
  • RHSA-2026:60363
  • RHSA-2026:69464
  • RHSA-2026:69466
  • RHSA-2026:69467
  • RHSA-2026:69469
  • RHSA-2026:70965
  • RHSA-2026:70969
  • RHSA-2026:70979
  • RHSA-2026:70995
  • RHSA-2026:76149
  • RHSA-2026:76150

Official advisory · high-confidence parse· fetched 14 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Official advisory · high-confidence parse· fetched 14 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.