Medium [CVE-2026-55956] Improper Authorization Allows Security Constraint Bypass
This medium-severity Red Hat Linux advisory covers CVE-2026-55956 affecting Red Hat Enterprise Linux 10.0 Extended Update Support, Red Hat Enterprise Linux 8.8 Telecommunications Update Service, Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.
Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue. A flaw was found in Apache Tomcat where access control rules for the default servlet are improperly handled.
An attacker can exploit this issue to bypass specific HTTP method restrictions, potentially gaining unauthorized access to protected application resources. Red Hat products utilizing affected Tomcat versions are vulnerable if they rely on these method-specific security constraints.
Red Hat severity: Moderate — CVSS 6.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N). Weakness: CWE-551.
Affected products named by the advisory: Red Hat Enterprise Linux 10.0 Extended Update Support; Red Hat Enterprise Linux 8.8 Telecommunications Update Service; Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions; Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions; and 17 more.
Is CVE-2026-55956 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-55956 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-55956?
Upgrade to a fixed release named by Red Hat:
- 11.0.23
- 10.1.56
- 9.0.119
- tomcat9-1:9.0.120-1.el10_2
- tomcat9-1:9.0.120-1.el10_0
- tomcat-1:9.0.120-1.el8_10
- tomcat-1:9.0.120-1.el8_8
- tomcat-1:9.0.120-2.el9_8
- tomcat-1:9.0.120-1.el9_2
- tomcat-1:9.0.120-1.el9_4
- tomcat-1:9.0.120-1.el9_6
- tomcat-catalina
22 more fixed releases are listed below.
Confirm against the vendor advisory before you patch.
- 11.0.0
- 11.0.22
- 10.1.0
- 10.1.55
- 9.0.0
- 9.0.118
- 8.5.0
- 8.5.100
- 7.0.0
- 7.0.109
Official advisory · high-confidence parse· fetched 12 days ago·verify at source
- 11.0.23
- 10.1.56
- 9.0.119
- tomcat9-1:9.0.120-1.el10_2
- tomcat9-1:9.0.120-1.el10_0
- tomcat-1:9.0.120-1.el8_10
- tomcat-1:9.0.120-1.el8_8
- tomcat-1:9.0.120-2.el9_8
- tomcat-1:9.0.120-1.el9_2
- tomcat-1:9.0.120-1.el9_4
- tomcat-1:9.0.120-1.el9_6
- tomcat-catalina
- jws6-tomcat-0:10.1.49-15.redhat_00013.1.el10jws
- jws6-tomcat-0:10.1.49-15.redhat_00013.1.el8jws
- jws6-tomcat-0:10.1.49-15.redhat_00013.1.el9jws
- jws7-tomcat-0:11.0.21-5.redhat_00004.1.el10jws
- jws7-tomcat-0:11.0.21-5.redhat_00004.1.el8jws
- jws7-tomcat-0:11.0.21-5.redhat_00004.1.el9jws
- tomcat10-main-10.1.56-1.hum1
- tomcat11-main-11.0.23-0.1.hum1
- RHSA-2026:68651
- RHSA-2026:67163
- RHSA-2026:68677
- RHSA-2026:68680
- RHSA-2026:68660
- RHSA-2026:68678
- RHSA-2026:68679
- RHSA-2026:68659
- RHSA-2026:43402
- RHSA-2026:43401
- RHSA-2026:39189
- RHSA-2026:39188
- RHSA-2026:29203
- RHSA-2026:32960
Official advisory · high-confidence parse· fetched 12 days ago·verify at source
Mitigation checklist
- Review your application's web.xml file. Ensure security constraints explicitly deny unauthorized users by path, rather than relying strictly on filtering specific HTTP methods (like GET or POST).
Official advisory · high-confidence parse· fetched 12 days ago·verify at source
Get an email when Red Hat RHEL & SELinux publishes the next one.
See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-34486Apr 9, 2026Missing Encryption of Sensitive Data due to EncryptInterceptor bypass
- CVE-2026-46300May 13, 2026"Fragnesia" is a variant of Dirty Frag vulnerability in the ESP/XFRM leading to Local
- CVE-2026-31431Apr 22, 2026algif_aead - Revert to operating out-of-place
- CVE-2025-31277Mar 18, 2026Processing maliciously crafted web content may lead to memory corruption
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-53362Jul 4, 2026account for fraggap on the paged allocation path
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.