Low [CVE-2026-56140] Apache Camel AWS SNS Component: Defense-in-depth hardening due to improper input validation
This low-severity Red Hat Linux advisory covers CVE-2026-56140.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
Improper Input Validation vulnerability in Apache Camel AWS SNS component. The camel-aws2-sns component filters Camel headers through a component-specific HeaderFilterStrategy, Sns2HeaderFilterStrategy.
Like the sibling Sqs2HeaderFilterStrategy, it originally configured only an outbound filter (setOutFilterPattern, which blocks Camel*, breadcrumbId and org.apache.camel.* headers from being written out) and did not configure an inbound filter rule.
As part of the same fix (CAMEL-23506), an inbound filter rule (setInFilterStartsWith for the Camel namespace) was added to Sns2HeaderFilterStrategy so that its configuration matches the corrected Sqs2HeaderFilterStrategy and the other sibling strategies. This is a defense-in-depth alignment with no known exploit path in camel-aws2-sns.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0. Users who want the aligned behaviour can upgrade to version 4.21.0, or to 4.14.8 on the 4.14.x LTS releases stream, or to 4.18.3 on the 4.18.x releases stream, which contain the change.
As a general best practice, operators should continue to apply least-privilege IAM permissions on their SNS topics. An improper input validation vulnerability exists in the `Sns2HeaderFilterStrategy` due to a missing inbound filter rule.
Is CVE-2026-56140 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-56140 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-56140?
Upgrade to a fixed release named by Red Hat:
- 4.21.0
- 4.14.8
- 4.14
- 4.18.3
- 4.18
Confirm against the vendor advisory before you patch.
- < 4.0.0
- < 4.14.8
- < 4.15.0
- < 4.18.3
- < 4.19.0
- < 4.21.0
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
- 4.21.0
- 4.14.8
- 4.14
- 4.18.3
- 4.18
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Mitigation checklist
- No urgent action is required as there is no known exploit path. Users who want the aligned behavior can upgrade to Apache Camel 4.21.0, 4.14.8, or 4.18.3.
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Get an email when Red Hat publishes the next one.
See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.