Skip to content
VulniPulse
Advisory severityMedium5.4Red Hat Linux

Medium [CVE-2026-57158] Information disclosure via truncated RDPGFX planar payload

This medium-severity Red Hat Linux advisory covers CVE-2026-57158 affecting Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-57158 Source published Source updated

VulniPulse record published Record updated

CVE-2026-57158
Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Summary

FreeRDP is a free implementation of the Remote Desktop Protocol.

From 3.21.0 before 3.28.0, FreeRDP clients using the GFX pipeline contain an incomplete fix for CVE-2026-23530 in planar_decompress_plane_rle_only in libfreerdp/codec/planar.c, allowing a malicious RDP server to send a truncated RDPGFX_CMDID_WIRETOSURFACE_1 planar payload that reads one byte past the input buffer. This issue is fixed in version 3.28.0.

FreeRDP clients using the Graphics (GFX) pipeline are vulnerable to an out-of-bounds read. A malicious RDP server can exploit this by sending a specially crafted, truncated RDPGFX_CMDID_WIRETOSURFACE_1 planar payload.

This can lead to reading one byte beyond the intended buffer, potentially disclosing sensitive information or causing a denial of service. Red Hat severity: Moderate — CVSS 5.4 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L).

Weakness: CWE-125. Affected Red Hat products: Red Hat Enterprise Linux 10; Red Hat Enterprise Linux 6; Red Hat Enterprise Linux 7; Red Hat Enterprise Linux 8; Red Hat Enterprise Linux 9.

Will not fix / out of support: Red Hat Enterprise Linux 6; Red Hat Enterprise Linux 7. Red Hat does not currently list a fixing RHSA for this CVE.

Affected products named by the advisory: Red Hat package: freerdp.

Is CVE-2026-57158 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-57158 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-57158?

Upgrade to a fixed release named by Red Hat:

  • 3.28.0

Confirm against the vendor advisory before you patch.

Affected versions
  • < 3.21.0
  • < 3.28.0

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Fixed versions
  • 3.28.0

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Official advisory · high-confidence parse· fetched 5 days ago·verify at source

Get an email when Red Hat RHEL & SELinux publishes the next one.

See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat RHEL & SELinux
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.