Critical [CVE-2026-57211] Information disclosure via path validation bypass in management plugin
This critical-severity Red Hat Linux advisory covers CVE-2026-57211 affecting Red Hat Hardened Images.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
RabbitMQ is a messaging and streaming broker.
Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_prim_loader:read_file_info before path validation when multiple management extension plugins are enabled, causing outbound DNS and SMB requests to attacker-controlled UNC paths.
This issue is fixed in versions 4.1.11 and 4.2.6. A flaw was found in RabbitMQ.
This can lead to outbound DNS and Server Message Block (SMB) requests to attacker-controlled network paths, potentially disclosing sensitive information. Red Hat severity: Critical — CVSS 10 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H).
Weakness: CWE-76. Affected Red Hat products: Red Hat Hardened Images.
Red Hat lists Red Hat OpenStack Platform 16.2; Red Hat OpenStack Platform 17.1; Red Hat OpenStack Platform 18.0 as not affected. Red Hat fixing advisory: RHSA-2026:35939, RHSA-2026:35940.
Is CVE-2026-57211 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-57211 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-57211?
Upgrade to a fixed release named by Red Hat:
- 4.1.11
- 4.2.6
- rabbitmq-server4-3-main-4.3.2-1.hum1
- rabbitmq-server4-2-main-4.2.8-1.hum1
- RHSA-2026:35939
- RHSA-2026:35940
Confirm against the vendor advisory before you patch.
- < 4.1.11
- < 4.2.6
Official advisory · high-confidence parse· fetched 1 day ago·verify at source
- 4.1.11
- 4.2.6
- rabbitmq-server4-3-main-4.3.2-1.hum1
- rabbitmq-server4-2-main-4.2.8-1.hum1
- RHSA-2026:35939
- RHSA-2026:35940
Official advisory · high-confidence parse· fetched 1 day ago·verify at source
Mitigation
Upgrade to a fixed release: 4.1.11, 4.2.6, rabbitmq-server4-3-main-4.3.2-1.hum1, rabbitmq-server4-2-main-4.2.8-1.hum1, RHSA-2026:35939, RHSA-2026:35940. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 1 day ago·verify at source
Get an email when Red Hat publishes the next one.
See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.