Skip to content
VulniPulse
Advisory severityHigh8.1Red Hat Linux

High [CVE-2026-57215] Persistent foreign bindings allow unauthorized message routing

This high-severity Red Hat Linux advisory covers CVE-2026-57215 affecting Red Hat Hardened Images.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-57215 Source published Source updated

VulniPulse record published Record updated

CVE-2026-57215
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ allows foreign bindings to amq.rabbitmq.reply-to destinations because volatile direct-reply-to queues can be accepted at bind and route time but are missing from Khepri-backed deletion checks, leaving persistent route entries after unbind.

This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6. This occurs because temporary queues are not properly removed, leaving behind active routing entries.

This can lead to unauthorized message routing and potential exposure of sensitive information. Red Hat severity: Important — CVSS 8.1 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N).

Weakness: CWE-459. Affected Red Hat products: Red Hat Hardened Images.

Red Hat lists Red Hat OpenStack Platform 16.2; Red Hat OpenStack Platform 17.1; Red Hat OpenStack Platform 18.0 as not affected. Red Hat fixing advisory: RHSA-2026:35939, RHSA-2026:35940.

Is CVE-2026-57215 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-57215 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-57215?

Upgrade to a fixed release named by Red Hat:

  • 3.13.15
  • 4.0.20
  • 4.1.11
  • 4.2.6
  • rabbitmq-server4-3-main-4.3.2-1.hum1
  • rabbitmq-server4-2-main-4.2.8-1.hum1
  • RHSA-2026:35939
  • RHSA-2026:35940

Confirm against the vendor advisory before you patch.

Affected versions
  • < 3.13.15
  • < 4.0.20
  • < 4.1.11
  • < 4.2.6

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Fixed versions
  • 3.13.15
  • 4.0.20
  • 4.1.11
  • 4.2.6
  • rabbitmq-server4-3-main-4.3.2-1.hum1
  • rabbitmq-server4-2-main-4.2.8-1.hum1
  • RHSA-2026:35939
  • RHSA-2026:35940

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Mitigation

Upgrade to a fixed release: 3.13.15, 4.0.20, 4.1.11, 4.2.6, rabbitmq-server4-3-main-4.3.2-1.hum1, rabbitmq-server4-2-main-4.2.8-1.hum1. That is the remediation for this advisory.

The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.