Skip to content
VulniPulse
Advisory severityHigh7.5Red Hat Linux

High [CVE-2026-57220] Denial of Service via oversized stream frames

This high-severity Red Hat Linux advisory covers CVE-2026-57220 affecting Red Hat Hardened Images.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-57220 Source published Source updated

VulniPulse record published Record updated

CVE-2026-57220
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

RabbitMQ is a messaging and streaming broker. This issue is fixed in version 4.2.6.

A flaw was found in RabbitMQ. The stream listener in RabbitMQ does not properly enforce frame-size limits during authentication and before negotiation.

This allows an unauthenticated remote client to send oversized stream frames, which can consume excessive broker memory. This can lead to a denial of service (DoS) condition, making the service unavailable to legitimate users.

Red Hat severity: Important — CVSS 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H). Weakness: CWE-770.

Affected Red Hat products: Red Hat Hardened Images. Red Hat lists Red Hat OpenStack Platform 16.2; Red Hat OpenStack Platform 17.1; Red Hat OpenStack Platform 18.0 as not affected.

Red Hat fixing advisory: RHSA-2026:35939, RHSA-2026:35940.

Is CVE-2026-57220 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-57220 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-57220?

Upgrade to a fixed release named by Red Hat:

  • 4.2.6
  • rabbitmq-server4-3-main-4.3.2-1.hum1
  • rabbitmq-server4-2-main-4.2.8-1.hum1
  • RHSA-2026:35939
  • RHSA-2026:35940

Confirm against the vendor advisory before you patch.

Affected versions
  • < 4.2.6

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Fixed versions
  • 4.2.6
  • rabbitmq-server4-3-main-4.3.2-1.hum1
  • rabbitmq-server4-2-main-4.2.8-1.hum1
  • RHSA-2026:35939
  • RHSA-2026:35940

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Mitigation

Upgrade to a fixed release: 4.2.6, rabbitmq-server4-3-main-4.3.2-1.hum1, rabbitmq-server4-2-main-4.2.8-1.hum1, RHSA-2026:35939, RHSA-2026:35940. That is the remediation for this advisory.

The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.

Official advisory · high-confidence parse· fetched 1 day ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.