Skip to content
VulniPulse
Advisory severityMedium6.5Red Hat Linux

Medium [CVE-2026-58207] Denial of Service via arithmetic overflow in connection monitoring pagination

This medium-severity Red Hat Linux advisory covers CVE-2026-58207 affecting Multicluster Global Hub, Red Hat Ceph Storage 5, Red Hat Ceph Storage 6.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-58207 Source published Source updated

VulniPulse record published Record updated

CVE-2026-58207
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client able to send account-scoped connection monitoring requests could crash the server by supplying Connz pagination Offset and Limit values that overflowed internal arithmetic before the response window was safely bounded.

This issue is fixed in versions 2.14.3 and 2.12.12. A flaw was found in NATS Server.

This is achieved by providing pagination offset and limit values that cause an arithmetic overflow, leading to a Denial of Service (DoS).

CVE.org and NVD independently assess this issue at different severities than Red Hat because CVE.org uses a Changed scope (S:C) in its CVSS vector, treating the crash as impacting components beyond the NATS Server process itself.

Red Hat, consistent with NVDs own scoring, assesses the impact as scoped to the NATS Server process (Scope Unchanged), resulting in a CVSS score of 6.5 and a Moderate impact rating.

Only account-scoped connection-monitoring requests can trigger the arithmetic overflow, and no Red Hat product runs an externally-reachable, unauthenticated NATS Server monitoring endpoint by default. Weakness: CWE-190.

Affected Red Hat products: Multicluster Global Hub; Red Hat Ceph Storage 5; Red Hat Ceph Storage 6; Red Hat Ceph Storage 7; Red Hat Ceph Storage 8; Red Hat Ceph Storage 9.

Is CVE-2026-58207 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-58207 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-58207?

Upgrade to a fixed release named by Red Hat:

  • 2.14.3
  • 2.12.12

Confirm against the vendor advisory before you patch.

Affected versions
  • < 2.14.3
  • < 2.12.12

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Fixed versions
  • 2.14.3
  • 2.12.12

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Upstream mitigation: restrict publish access to system request subjects (e.g. \.REQ.ACCOUNT.*.CONNZ) for untrusted clients, and avoid no-auth NATS deployments where untrusted clients can publish to system monitoring request subjects. Upgrading to nats-server 2.14.3 or 2.12.12 (or later) fully resolves the issue.

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.