High [CVE-2026-58459] Command Injection via GPS device subtype allows arbitrary code execution
This high-severity Red Hat Linux advisory covers CVE-2026-58459 affecting Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 9, Red Hat package: gpsd-minimal.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
gpsd through release-3.27.5, fixed at commit 4c06658, contains a command injection vulnerability in gpsprof that allows attackers who control the GPS device subtype value to execute arbitrary shell commands by embedding backtick payloads in the gnuplot plot title without proper escaping.
The subtype field sourced from a DEVICES JSON log entry or NMEA PGRMT sentence is written into a generated gnuplot program via a set title statement with only double-quote characters escaped, enabling arbitrary shell command execution as the user running gnuplot when the victim renders the generated plot through the gpsprof and gnuplot workflow.
A flaw was found in gpsd, a service application that monitors one or more GPSes or AIS receivers. When a user processes a specially crafted plot through gpsprof and gnuplot, these embedded commands can be executed, leading to arbitrary code execution on the system.
Exploitation requires user interaction. Red Hat severity: Important — CVSS 7.8 (CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H).
Weakness: CWE-78. Affected Red Hat products: Red Hat Enterprise Linux 10; Red Hat Enterprise Linux 9.
Red Hat fixing advisory: RHSA-2026:51075, RHSA-2026:51153.
Affected products named by the advisory: Red Hat package: gpsd-minimal.
Is CVE-2026-58459 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-58459 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-58459?
Upgrade to a fixed release named by Red Hat:
- gpsd-1:3.26.1-3.el10_2.1
- gpsd-minimal-1:3.26.1-2.el9_8.1
- RHSA-2026:51075
- RHSA-2026:51153
Confirm against the vendor advisory before you patch.
- 3.27.5
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
- gpsd-1:3.26.1-3.el10_2.1
- gpsd-minimal-1:3.26.1-2.el9_8.1
- RHSA-2026:51075
- RHSA-2026:51153
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Mitigation
Upgrade to a fixed release: gpsd-1:3.26.1-3.el10_2.1, gpsd-minimal-1:3.26.1-2.el9_8.1, RHSA-2026:51075, RHSA-2026:51153. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Get an email when Red Hat RHEL & SELinux publishes the next one.
See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.