Low [CVE-2026-59084] Insufficient documentation for EncryptInterceptor may lead to insecure configurations
This low-severity Red Hat Linux advisory covers CVE-2026-59084 affecting Red Hat Enterprise Linux 10.0 Extended Update Support, Red Hat Enterprise Linux 8.8 Telecommunications Update Service, Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.
Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Insufficient technical documentation regarding the secure configuration of the EncryptInterceptor component may lead to deployments with insecure settings.
This vulnerability could allow an attacker to exploit misconfigurations that arise from unclear guidance, potentially compromising the confidentiality or integrity of data processed by the affected system.
Without clear guidance on secure configuration, administrators might inadvertently deploy the interceptor in a way that weakens security, rather than a direct code flaw. This issue affects Red Hat products utilizing Apache Tomcat, including Red Hat Enterprise Linux and Red Hat JBoss Web Server.
Red Hat severity: Low — CVSS 3.8 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N). Weakness: CWE-1188.
Is CVE-2026-59084 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-59084 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-59084?
Upgrade to a fixed release named by Red Hat:
- 11.0.24
- 10.1.57
- 9.0.120
- tomcat9-1:9.0.120-1.el10_2
- tomcat9-1:9.0.120-1.el10_0
- tomcat-1:9.0.120-1.el8_10
- tomcat-1:9.0.120-1.el8_8
- tomcat-1:9.0.120-2.el9_8
- tomcat-1:9.0.120-1.el9_2
- tomcat-1:9.0.120-1.el9_4
- tomcat-1:9.0.120-1.el9_6
- tomcat11-main-11.0.24-0.1.hum1
11 more fixed releases are listed below.
Confirm against the vendor advisory before you patch.
- 11.0.0
- 11.0.23
- 10.1.0
- 10.1.56
- 9.0.13
- 9.0.119
- 8.5.38
- 8.5.100
- 7.0.100
- 7.0.109
Official advisory · high-confidence parse· fetched 4 hours ago·verify at source
- 11.0.24
- 10.1.57
- 9.0.120
- tomcat9-1:9.0.120-1.el10_2
- tomcat9-1:9.0.120-1.el10_0
- tomcat-1:9.0.120-1.el8_10
- tomcat-1:9.0.120-1.el8_8
- tomcat-1:9.0.120-2.el9_8
- tomcat-1:9.0.120-1.el9_2
- tomcat-1:9.0.120-1.el9_4
- tomcat-1:9.0.120-1.el9_6
- tomcat11-main-11.0.24-0.1.hum1
- tomcat10-main-10.1.57-1.hum1
- RHSA-2026:68651
- RHSA-2026:67163
- RHSA-2026:68677
- RHSA-2026:68680
- RHSA-2026:68660
- RHSA-2026:68678
- RHSA-2026:68679
- RHSA-2026:68659
- RHSA-2026:36872
- RHSA-2026:37767
Official advisory · high-confidence parse· fetched 4 hours ago·verify at source
Mitigation checklist
- To mitigate this issue, ensure that the EncryptInterceptor in Apache Tomcat is configured according to secure best practices. Review existing configurations of EncryptInterceptor to verify that all security requirements are met and that no insecure settings are in place. If the EncryptInterceptor is not actively used, no specific action is required.
Official advisory · high-confidence parse· fetched 4 hours ago·verify at source
Get an email when Red Hat RHEL & SELinux publishes the next one.
See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-34486Apr 9, 2026Missing Encryption of Sensitive Data due to EncryptInterceptor bypass
- CVE-2026-46300May 13, 2026"Fragnesia" is a variant of Dirty Frag vulnerability in the ESP/XFRM leading to Local
- CVE-2026-31431Apr 22, 2026algif_aead - Revert to operating out-of-place
- CVE-2025-31277Mar 18, 2026Processing maliciously crafted web content may lead to memory corruption
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-53362Jul 4, 2026account for fraggap on the paged allocation path
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.