High [CVE-2026-59820] Directory traversal via crafted skill archive upload
This high-severity Red Hat Linux advisory covers CVE-2026-59820 affecting Exploit Intelligence.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Summary
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.
Prior to 1.83.7-stable, LiteLLM Skills archive extraction did not sufficiently validate file paths from uploaded skill ZIP archives, allowing an authenticated user with access to LiteLLM LLM API routes or a key whose allowed_routes includes /v1/skills, anthropic_routes, or llm_api_routes to upload a crafted skill archive containing path traversal entries that could be written outside the intended extraction or staging directory.
This issue is fixed in version 1.83.7-stable. A flaw was found in LiteLLM, a proxy server for Large Language Model (LLM) APIs.
This vulnerability could lead to arbitrary file creation or modification, potentially resulting in system compromise. Exploitation requires the LiteLLM Proxy Server's Skills API (/v1/skills, anthropic_routes, or llm_api_routes) to be enabled and reachable by an authenticated caller.
Red Hat severity: Important — CVSS 8.1 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H). Weakness: CWE-22.
Affected Red Hat products: Exploit Intelligence. Red Hat lists Lightspeed Core; Red Hat Ansible Automation Platform 2; Red Hat OpenShift AI (RHOAI) as not affected.
Red Hat does not currently list a fixing RHSA for this CVE.
Is CVE-2026-59820 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-59820 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-59820?
Upgrade to a fixed release named by Red Hat:
- 1.83.7
- 1.83.7-stable
Confirm against the vendor advisory before you patch.
- < 1.83.7-stable
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
- 1.83.7
- 1.83.7-stable
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Mitigation checklist
- Upgrade to LiteLLM 1.83.7-stable or later. Products that use LiteLLM only as a Python SDK (litellm.completion()) rather than running the LiteLLM Proxy Server with the Skills feature enabled are not exposed to this vulnerability, as the vulnerable HTTP upload endpoint does not exist in SDK-only usage.
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Get an email when Red Hat publishes the next one.
See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
More Red Hat Linux advisories
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.