Skip to content
VulniPulse
Advisory severityHigh7.2Red Hat Linux

High [CVE-2026-59821] Arbitrary code execution and information disclosure via custom code guardrails

This high-severity Red Hat Linux advisory covers CVE-2026-59821.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-59821 Source published Source updated

VulniPulse record published Record updated

CVE-2026-59821
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.

Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process.

This issue is fixed in version 1.82.0-stable. A flaw was found in LiteLLM, a proxy server for Large Language Model (LLM) APIs.

The flaw allowed the user to submit custom Python code that would execute within the LiteLLM proxy environment, potentially exposing sensitive information or secrets accessible to the process. Red Hat rates this flaw with higher severity than the upstream GitHub Security Advisory (GHSA-72m8-9m7m-h278, CVSS v4.0 2.1, Low).

Red Hat scored this CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H (7.2, Important) because a successful exploit grants arbitrary Python code execution within the LiteLLM proxy process, resulting in full compromise of the confidentiality, integrity, and availability of that component, including exposure of any secrets accessible to the process.

Is CVE-2026-59821 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-59821 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-59821?

Upgrade to a fixed release named by Red Hat:

  • 1.82.0
  • 1.82.0-stable

Confirm against the vendor advisory before you patch.

Affected versions
  • < 1.82.0-stable

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Fixed versions
  • 1.82.0
  • 1.82.0-stable

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Upgrade litellm to 1.82.0 or later, which enforces the same code-safety checks on the guardrail create/update endpoints as the test endpoint. If upgrading is not immediately possible, restrict access to POST /guardrails and PUT /guardrails/{guardrail_id} to trusted administrators only, ensure LITELLM_MASTER_KEY is configured so unauthenticated callers are not treated as proxy administrators, and avoid enabling Custom Code Guardrails for untrusted users.

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.