Skip to content
VulniPulse
Advisory severityMedium5.3Red Hat Linux

Medium [CVE-2026-59927] Denial of Service via unbounded recursion in Markdown include directive

This medium-severity Red Hat Linux advisory covers CVE-2026-59927 affecting Migration Toolkit for Applications 8, Red Hat OpenShift AI (RHOAI), Red Hat OpenShift Container Platform 4.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-59927 Source published Source updated

VulniPulse record published Record updated

CVE-2026-59927
Affected products & platforms
Red Hat LinuxUnclassified
Open source advisory

Summary

Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.3.0, the Include directive in src/mistune/directives/include.py detects only direct self-includes and not indirect cycles, allowing two markdown files that include each other to trigger unbounded recursion, raise RecursionError, and crash the rendering request.

This issue is fixed in version 3.3.0. This oversight allows for unbounded recursion, which can lead to a `RecursionError` and crash the rendering request, resulting in a Denial of Service (DoS) for the application using the parser.

This flaw in the Mistune Include directive can cause a denial of service when an application explicitly enables the Include plugin and renders user-controlled Markdown files from disk.

Exploitation requires an attacker to place at least two coordinated Markdown files on the include search path; default Mistune configurations that parse inline strings without the Include plugin are not affected. Red Hat severity: Moderate — CVSS 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

Weakness: CWE-835. Affected Red Hat products: Migration Toolkit for Applications 8; Red Hat OpenShift AI (RHOAI); Red Hat OpenShift Container Platform 4; Red Hat Satellite 6.

Red Hat does not currently list a fixing RHSA for this CVE.

Is CVE-2026-59927 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-59927 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-59927?

Upgrade to a fixed release named by Red Hat:

  • 3.3.0

Confirm against the vendor advisory before you patch.

Affected versions
  • < 3.3.0

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Fixed versions
  • 3.3.0

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • To mitigate this issue, Red Hat recommends avoiding the processing of untrusted Markdown content that may contain recursively linked include directives. Users should ensure that any Markdown files processed by applications utilizing Mistune are from trusted sources or are thoroughly sanitized to prevent indirect cyclic inclusions.

Official advisory · high-confidence parse· fetched 13 days ago·verify at source

Get an email when Red Hat publishes the next one.

See Red Hat's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.