Skip to content
VulniPulse
Advisory severityHigh7.5Red Hat Linux

High [CVE-2026-59939] Denial of Service via unbounded decompression of HTTP response bodies

This high-severity Red Hat Linux advisory covers CVE-2026-59939 affecting Red Hat Enterprise Linux 10.0 Extended Update Support, Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support, Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-59939 Source published Source updated

VulniPulse record published Record updated

CVE-2026-59939
Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Summary

httplib2 is a comprehensive HTTP client library for Python.

Prior to 0.32.0, httplib2 performs unbounded decompression of HTTP response bodies encoded with Content-Encoding: gzip or deflate in _decompressContent in httplib2/init.py, allowing a malicious or compromised HTTP server to return a small compressed payload that expands to an arbitrarily large size in memory and causes MemoryError or OOM-kill in the client process.

This issue is fixed in version 0.32.0. This unbounded decompression can lead to a Denial of Service (DoS) by causing the client application to run out of memory and crash.

This Important vulnerability in `httplib2` allows a remote attacker to trigger a Denial of Service (DoS) in client applications. By sending a specially crafted, compressed HTTP response, a malicious server can cause the client to exhaust its memory due to unbounded decompression, leading to application crashes.

This poses a significant risk to Red Hat products that use `httplib2` to process untrusted HTTP content. Red Hat severity: Important — CVSS 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).

Weakness: CWE-409.

Is CVE-2026-59939 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-59939 is not in the CISA KEV catalog (checked ) and this advisory does not report exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-59939?

Upgrade to a fixed release named by Red Hat:

  • 0.32.0
  • fence-agents-0:4.16.0-21.el10_2.5
  • fence-agents-0:4.16.0-5.el10_0.12
  • fence-agents-0:4.2.1-129.el8_10.27
  • fence-agents-0:4.2.1-65.el8_4.30
  • fence-agents-0:4.2.1-89.el8_6.24
  • fence-agents-0:4.2.1-112.el8_8.19
  • fence-agents-0:4.10.0-110.el9_8.5
  • fence-agents-0:4.10.0-43.el9_2.24
  • fence-agents-0:4.10.0-62.el9_4.27
  • fence-agents-0:4.10.0-86.el9_6.19
  • ansible-automation-platform-25/lightspeed-rhel8:1785430174

19 more fixed releases are listed below.

Confirm against the vendor advisory before you patch.

Affected versions
  • < 0.32.0

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Fixed versions
  • 0.32.0
  • fence-agents-0:4.16.0-21.el10_2.5
  • fence-agents-0:4.16.0-5.el10_0.12
  • fence-agents-0:4.2.1-129.el8_10.27
  • fence-agents-0:4.2.1-65.el8_4.30
  • fence-agents-0:4.2.1-89.el8_6.24
  • fence-agents-0:4.2.1-112.el8_8.19
  • fence-agents-0:4.10.0-110.el9_8.5
  • fence-agents-0:4.10.0-43.el9_2.24
  • fence-agents-0:4.10.0-62.el9_4.27
  • fence-agents-0:4.10.0-86.el9_6.19
  • ansible-automation-platform-25/lightspeed-rhel8:1785430174
  • ansible-automation-platform-26/lightspeed-rhel9:1785775360
  • ansible-automation-platform-27/lightspeed-rhel9:1785375273
  • mta/mta-solution-server-rhel9:1784109883
  • rhoai/odh-trustyai-garak-lls-provider-dsp-rhel9:1791785804
  • RHSA-2026:48585
  • RHSA-2026:49911
  • RHSA-2026:47736
  • RHSA-2026:48615
  • RHSA-2026:48604
  • RHSA-2026:48605
  • RHSA-2026:50317
  • RHSA-2026:50653
  • RHSA-2026:50655
  • RHSA-2026:50654
  • RHSA-2026:50357
  • RHSA-2026:50479
  • RHSA-2026:50340
  • RHSA-2026:43038
  • RHSA-2026:84734

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Official advisory · high-confidence parse· fetched 11 days ago·verify at source

Get an email when Red Hat RHEL & SELinux publishes the next one.

See Red Hat RHEL & SELinux's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Red Hat RHEL & SELinux
All Red Hat Linux advisories

iPhone and Android apps · New on the App Store

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.