High [CVE-2026-64646] Denial of Service via excessive memory consumption in Server Actions
This high-severity Red Hat Linux advisory covers CVE-2026-64646 affecting Streams for Apache Kafka 3.2.1, Red Hat Enterprise Linux AI (RHEL AI) 3, streams for Apache Kafka 2.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Red Hat Linux publishes the next one.
VulniPulse checks Red Hat Linux's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive memory consumption if that Server Actions uses the Edge runtime.
This issue has been fixed in versions 15.5.21 and 16.2.11. A flaw was found in Next.js.
This can lead to a denial of service (DoS) due to resource exhaustion. An Important denial of service flaw exists in Next.js applications utilizing the App Router with Server Actions configured to use the Edge runtime.
This vulnerability can lead to excessive memory consumption, potentially causing service unavailability. Red Hat products that embed or deploy Next.js applications with this specific configuration are affected.
Red Hat severity: Important — CVSS 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H). Weakness: CWE-770.
Affected Red Hat products: Streams for Apache Kafka 3.2.1; Red Hat Enterprise Linux AI (RHEL AI) 3; streams for Apache Kafka 2. Red Hat lists Red Hat Enterprise Linux 10; Red Hat Enterprise Linux 7; Red Hat Enterprise Linux 8; Red Hat Enterprise Linux 9; Red Hat Trusted Artifact Signer as not affected.
Red Hat fixing advisory: RHSA-2026:54435.
- 13.0.0
- 15.5.20
- 16.0.0
- 16.2.10
Official advisory · high-confidence parse· fetched 27 days ago·verify at source
- 15.5.21
- 16.2.11
- next
- RHSA-2026:54435
Official advisory · high-confidence parse· fetched 27 days ago·verify at source
Mitigation
Upgrade to a fixed release: 15.5.21, 16.2.11, next, RHSA-2026:54435. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 27 days ago·verify at source
More Red Hat Linux advisories
- CVE-2026-48710May 26, 2026Security restriction bypass via malformed HTTP Host header
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
Android app · Google Play
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.