High [CVE-2026-66066] Remote Code Execution via Unsafe libvips Operations
This high-severity Red Hat Linux advisory covers CVE-2026-66066.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Red Hat Linux publishes the next one.
See Red Hat Linux's last 90 days of advisories first. Then choose the free weekly digest, or a free month of real-time alerts with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
Summary
Action Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload to invoke such an operation.
Consuming applications are affected when configured to use libvips and accept image uploads from untrusted users. An unauthenticated attacker may exploit this behavior to read arbitrary files accessible to the Rails process, including environment variables and application secrets.
Exposure of credentials such as secret_key_base or external-service tokens may enable remote code execution or lateral movement. This issue has been fixed in versions 7.2.3.2, 8.0.5.1 and 8.1.3.1.
A flaw was found in Active Storage, a component of Action Pack. An unauthenticated attacker can exploit this vulnerability by crafting a malicious file upload.
This Important flaw in Active Storage allows unauthenticated remote attackers to read arbitrary files and potentially achieve remote code execution. This occurs in applications configured with `libvips` as the Active Storage variant processor (a default since Rails 7.0) that accept untrusted image uploads.
Red Hat Satellite: The Active Storage engine is explicitly commented out and disabled at runtime across all Satellite/Foreman builds.
- < 7.2.3.2
- < 8.0.5.1
- < 8.1.3.1
Official advisory · high-confidence parse· fetched 1 month ago·verify at source
- 7.2.3.2
- 8.0.5.1
- 8.1.3.1
Official advisory · high-confidence parse· fetched 1 month ago·verify at source
Mitigation
Upgrade to a fixed release: 7.2.3.2, 8.0.5.1, 8.1.3.1. That is the remediation for this advisory.
The vendor advisory may list interim mitigations or workarounds not captured here. Review it before change work.
Official advisory · high-confidence parse· fetched 1 month ago·verify at source
More Red Hat Linux advisories
- CVE-2026-119977Oct 31, 2026Arbitrary code execution via predictable upgrade staging paths
- CVE-2026-111497Oct 22, 2026Out-of-Bounds Write in Google Brotli Decoder
- CVE-2026-109619Oct 21, 2026fatal error handling retains stale request state leading to use-after-free
- CVE-2026-109618Oct 21, 2026OOM bailout during request parsing leads to memory corruption and RCE
- CVE-2026-97229Oct 13, 2026integer overflow issue in CI/CD regular expression compiler
- CVE-2026-64849Aug 17, 2026Unauthenticated full-read SSRF in webhook delivery: _validate_webhook_url bypassed
iPhone and Android apps · New on the App Store
Monitor future Red Hat Linux CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.