Skip to content
VulniPulse
Advisory severityLow2.7Red Hat Linux

Low [CVE-2026-66422] Improper Authorization allows bypass of declarative role constraints

This low-severity Red Hat Linux advisory covers CVE-2026-66422 affecting Red Hat JBoss Web Server 6.2.5, Red Hat JBoss Web Server 6.2 on RHEL 10, Red Hat JBoss Web Server 6.2 on RHEL 8.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-66422 Source published Source updated

VulniPulse record published Record updated

Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Get an email when Red Hat Linux publishes the next one.

VulniPulse checks Red Hat Linux's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue. This misconfiguration allows for a bypass of declarative role constraints, which could lead to unauthorized access to resources that should be restricted based on user roles.

This vulnerability is rated as Low impact. It requires high privileges to exploit and only affects the confidentiality of information by allowing a bypass of declarative role constraints.

In Red Hat deployments, where Apache Tomcat instances are typically configured with strict access controls, this flaw primarily impacts already highly privileged users, limiting its overall risk. Red Hat severity: Low — CVSS 2.7 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N).

Weakness: CWE-386.

Affected versions
  • 11.0.0
  • 11.0.24
  • 10.1.0
  • 10.1.57
  • 9.0.25
  • 9.0.120
  • 8.5.46
  • 8.5.100
  • 7.0.97
  • 7.0.109

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

Fixed versions
  • 11.0.25
  • 10.1.58
  • 9.0.121
  • tomcat
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el10jws
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el8jws
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el9jws
  • tomcat11-main-11.0.25-0.1.hum1
  • tomcat10-main-10.1.59-0.1.hum1
  • RHSA-2026:73982
  • RHSA-2026:73981
  • RHSA-2026:56039
  • RHSA-2026:63137

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

All Red Hat Linux advisories

Android app · Google Play

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.