Skip to content
VulniPulse
Advisory severityMedium6.5Red Hat Linux

Medium [CVE-2026-68525] Unauthorized resource access via FORM authentication bypass

This medium-severity Red Hat Linux advisory covers CVE-2026-68525 affecting Red Hat JBoss Web Server 6.2.5, Red Hat JBoss Web Server 6.2 on RHEL 10, Red Hat JBoss Web Server 6.2 on RHEL 8.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-68525 Source published Source updated

VulniPulse record published Record updated

Affected products & platforms
Red Hat LinuxRed Hat Enterprise Linux
Open source advisory

Get an email when Red Hat Linux publishes the next one.

VulniPulse checks Red Hat Linux's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue. This bypass enables unauthorized access to resources via a GET request, even when those resources are intended to be restricted to POST requests only.

This Moderate impact vulnerability in Apache Tomcat's FORM authentication process, as utilized in Red Hat JBoss Web Server, allows an attacker to bypass security constraints for POST requests.

This enables unauthorized access to resources that are configured to restrict POST access while permitting GET, potentially leading to unintended data exposure or manipulation. Red Hat severity: Moderate — CVSS 6.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N).

Weakness: CWE-551.

Affected versions
  • 11.0.0
  • 11.0.24
  • 10.1.0
  • 10.1.57
  • 9.0.0
  • 9.0.120
  • 8.5.0
  • 8.5.100
  • 7.0.0
  • 7.0.109

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

Fixed versions
  • 11.0.25
  • 10.1.58
  • 9.0.121
  • tomcat
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el10jws
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el8jws
  • jws6-tomcat-0:10.1.49-16.redhat_00016.1.el9jws
  • tomcat11-main-11.0.25-0.1.hum1
  • tomcat10-main-10.1.59-0.1.hum1
  • RHSA-2026:73982
  • RHSA-2026:73981
  • RHSA-2026:56039
  • RHSA-2026:63137

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Official advisory · high-confidence parse· fetched 21 days ago·verify at source

All Red Hat Linux advisories

Android app · Google Play

Monitor future Red Hat Linux CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.