High [CVE-2026-0319] PAN-OS: Improper Input Handling Vulnerability
This high-severity Palo Alto Networks advisory covers CVE-2026-0319 affecting PAN-OS, Prisma Access.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Palo Alto Networks publishes the next one.
VulniPulse checks Palo Alto Networks's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
CVE-2026-0319 PAN-OS: Improper Input Handling Vulnerability
Affected products named by the advisory: Prisma Access.
- PAN-OS 12.2: < 12.2.4
- PAN-OS 12.1: < 12.1.4-h12< 12.1.7-h8< 12.1.10-h2
- PAN-OS 11.2: < 11.2.4-h22< 11.2.7-h21< 11.2.10-h15< 11.2.13-h3< 11.2.16
- PAN-OS 11.1: < 11.1.4-h37< 11.1.6-h39< 11.1.7-h11< 11.1.10-h35< 11.1.13-h15< 11.1.16-h3
- PAN-OS 10.2: < 10.2.7-h38< 10.2.10-h41< 10.2.13-h26< 10.2.16-h11< 10.2.18-h12
- Prisma Access 12.1: < 12.1.7-h8
- Prisma Access 11.2: < 11.2.7-h21
- Prisma Access 10.2: < 10.2.10-h41
Official advisory · high-confidence parse· fetched 8 days ago·verify at source
- PAN-OS >= 12.2.4
- PAN-OS >= 12.1.10-h2
- PAN-OS >= 12.1.7-h8
- PAN-OS >= 12.1.4-h12
- PAN-OS >= 11.2.16
- PAN-OS >= 11.2.13-h3
- PAN-OS >= 11.2.10-h15
- PAN-OS >= 11.2.7-h21
- PAN-OS >= 11.2.4-h22
- PAN-OS >= 11.1.16-h3
- PAN-OS >= 11.1.13-h15
- PAN-OS >= 11.1.10-h35
- PAN-OS >= 11.1.7-h11
- PAN-OS >= 11.1.6-h39
- PAN-OS >= 11.1.4-h37
- PAN-OS >= 10.2.18-h12
- PAN-OS >= 10.2.16-h11
- PAN-OS >= 10.2.13-h26
- PAN-OS >= 10.2.10-h41
- PAN-OS >= 10.2.7-h38
Official advisory · high-confidence parse· fetched 8 days ago·verify at source
Mitigation checklist
- VersionMinor VersionSuggested SolutionCloud NGFWNo action needed.
- PAN-OS 12.2 12.2.0 through 12.2.3 Upgrade to 12.2.4 or later.
- PAN-OS 12.1 12.1.8 through 12.1.10-h* Upgrade to 12.1.10-h2 or later. 12.1.5 through 12.1.7-h* Upgrade to 12.1.7-h8 or 12.1.10-h2 or later. 12.1.2 through 12.1.4-h* Upgrade to 12.1.4-h12 or 12.1.10-h2 or later.
- No known workarounds exist for this issue.
Official advisory · high-confidence parse· fetched 8 days ago·verify at source
More Palo Alto Networks advisories
- CVE-2026-0321Oct 14, 2026PAN-OS: Denial of Service (DoS) Vulnerabilities in Network Services
- CVE-2026-0310Sep 9, 2026PAN-OS: Buffer Overflow Vulnerability via XML Processing
- CVE-2026-0301Aug 12, 2026PAN-OS: Information Disclosure Vulnerability in URL Filtering
- CVE-2026-0287Jul 8, 2026PAN-OS: Denial of Service Vulnerabilities in Network Traffic Processing
- CVE-2026-0288Jul 8, 2026PAN-OS: Buffer Overflow Vulnerabilities in User-ID Terminal Server Agent
- CVE-2026-0280Jul 8, 2026PAN-OS: IPv6 Firewall Policy Bypass
Android app · Google Play
Monitor future Palo Alto Networks CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.