Skip to content
VulniPulse
Highest advisory severityHigh 2 vendors · 2 advisories

CVE-2026-41608

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings

CVE-2026-41608: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. Not in the CISA KEV catalog.

Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.

Get an email when Apache publishes the next one.

VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

CVE-2026-41608 key facts

CISA KEV
Not listed (catalog checked )
Highest advisory severity
High
CVSS base score
7.5 (Apache), 7.5 (Red Hat)
CVSS vector
  • CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H (Red Hat)
Weakness
CWE-409
Fixed releases
  • Apache: 0.24.0
  • Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
Vendor advisories
2 from Apache, Red Hat
VulniPulse record
Published · Updated

Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-41608; bulletin-wide values are not repeated here.

Is CVE-2026-41608 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-41608 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-41608?

Upgrade to a fixed release named by the vendor:

  • Apache: 0.24.0
  • Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
  • Users are recommended to upgrade to version 0.24.0, which fixes the issue. (Apache)

Vendor advisory comparison

Apache

1 advisory

Red Hat

1 advisory
  • Advisory severityHigh7.5

    High [CVE-2026-41608] Apache Thrift Python bindings: Denial of Service via data amplification

    CVE-2026-41608Source published Source updated

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. An attacker could exploit this by providing specially crafted compressed input, which may cause the application to consume excessive resources. This could potentially result in a denial of service (DoS) for affected systems. Red Hat severity: Important — CVSS 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H). Weakness: CWE-409. Affected Red Hat products: Red Hat Hardened Images. Red Hat lists Confidential Compute Attestation; Red Hat Enterprise Linux AI (RHEL AI) 3; Red Hat OpenShift Container Platform 4; Red Hat OpenShift Update Service as not affected.…

    Affected products in this advisory
    • Red Hat Hardened Images
    Source-reported affected versions
    • < 0.24.0
    Source-reported fixed versions
    • 0.24.0
    • thrift-main-0.24.0-0.1.hum1
    • RHSA-2026:49837
    Mitigation guidance
    No mitigation guidance extracted; consult the source.
All Apache advisories

Follow CVE-2026-41608 in the free weekly digest

Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.

Free, no account. Confirm by email; unsubscribe in one click. Choose vendors and severity

Browse the latest tracked CVEs or the CVEs listed in CISA KEV.

Android app · Google Play

Get alerts for new CVEs on your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Matching phone alertsOptional email delivery