CVE-2026-49158
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings
CVE-2026-49158: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. Not in the CISA KEV catalog.
Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.
Get an email when Apache publishes the next one.
VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
CVE-2026-49158 key facts
- CISA KEV
- Not listed (catalog checked )
- Highest advisory severity
- High
- CVSS base score
- 7.5 (Apache), 7.5 (Red Hat)
- CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H(Red Hat)
- Weakness
- CWE-409
- Fixed releases
- Apache: 0.24.0
- Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
- VulniPulse record
- Published · Updated
Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-49158; bulletin-wide values are not repeated here.
Is CVE-2026-49158 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-49158 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-49158?
Upgrade to a fixed release named by the vendor:
- Apache: 0.24.0
- Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
- Users are recommended to upgrade to version 0.24.0, which fixes the issue. (Apache)
- Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability. (Red Hat)
Vendor advisory comparison
Apache
1 advisory- Advisory severityHigh7.5
High [CVE-2026-49158] Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings
CVE-2026-49158Source published Source updated
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
- Affected products in this advisory
- Apache Thrift Ruby
- Source-reported affected versions
- 0.24.0
- Source-reported fixed versions
- 0.24.0
- Mitigation guidance
- Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Red Hat
1 advisory- Advisory severityHigh7.5
High [CVE-2026-49158] Apache Thrift Ruby bindings: Denial of Service via improper handling of highly compressed data
CVE-2026-49158Source published Source updated
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. By sending specially crafted highly compressed data, an attacker can exhaust system resources, making the service unavailable to legitimate users. This Important vulnerability in Apache Thrift Ruby bindings could allow a remote, unauthenticated attacker to trigger a denial of service. By sending specially crafted compressed data, an attacker can cause excessive resource consumption, leading to service unavailability in affected Red Hat products that utilize these bindings, such as OpenShift Container Platform components. Red Hat severity: Important — CVSS…
- Affected products in this advisory
- Red Hat Hardened Images
- Source-reported affected versions
- < 0.24.0
- Source-reported fixed versions
- 0.24.0
- thrift-main-0.24.0-0.1.hum1
- RHSA-2026:49837
- Mitigation guidance
- Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
More Apache advisories
- CVE-2026-96277Oct 2, 2026Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache
- CVE-2026-114349Oct 28, 2026Apache Kafka: When a broker decodes a compressed record batch, the per-record decoder
- CVE-2026-112375Oct 28, 2026Apache Kafka: authenticated Kafka principal with no authorization grants
- CVE-2026-116593Oct 28, 2026Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint
- CVE-2026-115644Oct 28, 2026Apache Kafka Connect contains an authentication bypass vulnerability affecting the admin
- CVE-2026-111551Oct 28, 2026Apache Kafka: Several Kafka deserialization paths read a size or count field from input
Follow CVE-2026-49158 in the free weekly digest
Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.
Browse the latest tracked CVEs or the CVEs listed in CISA KEV.
Android app · Google Play
Get alerts for new CVEs on your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.