CVE-2026-55971
Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings
CVE-2026-55971: Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. Not in the CISA KEV catalog.
Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.
Get an email when Apache publishes the next one.
VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
CVE-2026-55971 key facts
- CISA KEV
- Not listed (catalog checked )
- Highest advisory severity
- Critical
- CVSS base score
- 9.3 (Apache), 8.4 (Red Hat)
- Fixed releases
- Apache: 0.24.0
- Red Hat: 0.24.0, thrift-0:0.24.0-1.el9ai, thrift-0:0.24.0-2.el9ai, thrift-main-0.24.0-0.1.hum1, rhai/base-image-neuron-rhel9:1790703542, RHSA-2026:49716 and 4 more in the advisory
- VulniPulse record
- Published · Updated
Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-55971; bulletin-wide values are not repeated here.
Is CVE-2026-55971 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-55971 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-55971?
Upgrade to a fixed release named by the vendor:
- Apache: 0.24.0
- Red Hat: 0.24.0, thrift-0:0.24.0-1.el9ai, thrift-0:0.24.0-2.el9ai, thrift-main-0.24.0-0.1.hum1, rhai/base-image-neuron-rhel9:1790703542, RHSA-2026:49716
- Users are recommended to upgrade to version 0.24.0, which fixes the issue. (Apache)
- No mitigation is available other than upgrading to Apache Thrift 0.24.0 or later, which contains the fix. AIPCC's PyArrow build pipeline is tracked separately for remediation under AIPCC-28667. (Red Hat)
Vendor advisory comparison
Apache
1 advisory- Advisory severityCritical9.3
Critical [CVE-2026-55971] Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings
CVE-2026-55971Source published Source updated
Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
- Affected products in this advisory
- Apache Thrift
- Source-reported affected versions
- 0.24.0
- Source-reported fixed versions
- 0.24.0
- Mitigation guidance
- Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Red Hat
1 advisory- Advisory severityHigh8.4
High [CVE-2026-55971] Apache Thrift C++ bindings: Remote code execution via heap-based buffer overflow
CVE-2026-55971Source published Source updated
Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. A remote, unauthenticated attacker can exploit a heap-based buffer overflow vulnerability without user interaction. This can lead to arbitrary code execution, allowing the attacker to gain full control over the affected system, compromise data, and cause a denial of service. Red Hat ships the affected C++ package (thrift) in RHEL AI and in the Fedora/EPEL community distributions, and it is also consumed by AIPCC's PyArrow build pipeline (tracked separately as AIPCC-28667); upgrade to Apache Thrift 0.24.0 or later to remediate. Confirmed usage in RHEL AI 3.4's GPU bootc images and in the AIPCC…
- Affected products in this advisory
- Red Hat Enterprise Linux AI 3.4 for RHEL 9
- Red Hat Enterprise Linux AI 3.5 for RHEL 9
- Red Hat Enterprise Linux AI 3.6 for RHEL 9
- Red Hat Hardened Images
1 more entries in the full advisory.
- Source-reported affected versions
- < 0.24.0
- Source-reported fixed versions
- 0.24.0
- thrift-0:0.24.0-1.el9ai
- thrift-0:0.24.0-2.el9ai
- thrift-main-0.24.0-0.1.hum1
6 more entries in the full advisory.
- Mitigation guidance
- No mitigation is available other than upgrading to Apache Thrift 0.24.0 or later, which contains the fix. AIPCC's PyArrow build pipeline is tracked separately for remediation under AIPCC-28667.
More Apache advisories
- CVE-2026-82231Oct 21, 2026Apache Thrift: Thrift client in Apache bRPC
- CVE-2026-66054Oct 2, 2026Allocation of Resources Without Limits or Throttling, Improper Handling of Highly
- CVE-2026-63772Oct 2, 2026Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift go
- CVE-2026-66055Oct 2, 2026Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift C++
- CVE-2026-66081Oct 2, 2026Access of Uninitialized Pointer vulnerability in Apache Thrift c_glib bindings
- CVE-2026-66837Oct 2, 2026Stack-based Buffer Overflow, Integer Overflow or Wraparound vulnerability in Apache Thrift
Follow CVE-2026-55971 in the free weekly digest
Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.
Browse the latest tracked CVEs or the CVEs listed in CISA KEV.
Android app · Google Play
Get alerts for new CVEs on your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.