Skip to content
VulniPulse
Highest advisory severityMedium 2 vendors · 2 advisories

CVE-2026-58023

Out-of-bounds Read vulnerability in Apache Thrift c_glib bindings

CVE-2026-58023: Out-of-bounds Read vulnerability in Apache Thrift c_glib bindings. Not in the CISA KEV catalog. Medium advisory severity (CVSS 6.9, Apache).

Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.

Get an email when Apache publishes the next one.

VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

CVE-2026-58023 key facts

CISA KEV
Not listed (catalog checked )
Highest advisory severity
Medium
CVSS base score
6.9 (Apache), 6.5 (Red Hat)
CVSS vector
  • CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L (Red Hat)
Weakness
CWE-125
Fixed releases
  • Apache: 0.24.0
  • Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
Vendor advisories
2 from Apache, Red Hat
VulniPulse record
Published · Updated

Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-58023; bulletin-wide values are not repeated here.

Is CVE-2026-58023 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-58023 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-58023?

Upgrade to a fixed release named by the vendor:

  • Apache: 0.24.0
  • Red Hat: 0.24.0, thrift-main-0.24.0-0.1.hum1, RHSA-2026:49837
  • Users are recommended to upgrade to version 0.24.0, which fixes the issue. (Apache)

Vendor advisory comparison

Apache

1 advisory

Red Hat

1 advisory
  • Advisory severityMedium6.5

    Medium [CVE-2026-58023] Information disclosure and denial of service due to out-of-bounds read

    CVE-2026-58023Source published Source updated

    Out-of-bounds Read vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This out-of-bounds read vulnerability allows an attacker to potentially access sensitive information or cause a denial of service. The vulnerability occurs when the software attempts to read data beyond the allocated memory buffer. Red Hat products such as OpenShift Container Platform, Red Hat OpenShift Update Service, and Confidential Compute Attestation are affected where they utilize vulnerable versions of Apache Thrift. Red Hat Enterprise Linux AI is not affected as the vulnerable code is not present. Red Hat severity: Moderate — CVSS 6.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L). Weakness…

    Affected products in this advisory
    • Red Hat Hardened Images
    Source-reported affected versions
    • < 0.24.0
    Source-reported fixed versions
    • 0.24.0
    • thrift-main-0.24.0-0.1.hum1
    • RHSA-2026:49837
    Mitigation guidance
    No mitigation guidance extracted; consult the source.
All Apache advisories

Follow CVE-2026-58023 in the free weekly digest

Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.

Free, no account. Confirm by email; unsubscribe in one click. Choose vendors and severity

Browse the latest tracked CVEs or the CVEs listed in CISA KEV.

Android app · Google Play

Get alerts for new CVEs on your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Matching phone alertsOptional email delivery