CVE-2026-68569
Apache Tomcat: Principal lookup can fail open in some cases
CVE-2026-68569: Apache Tomcat: Principal lookup can fail open in some cases. Not in the CISA KEV catalog. High advisory severity (CVSS 8.2, Red Hat).
Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.
Get an email when Apache publishes the next one.
VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
CVE-2026-68569 key facts
- CISA KEV
- Not listed (catalog checked )
- Highest advisory severity
- High
- CVSS base score
- 8.2 (Red Hat), 8.1 (Apache), 8.1 (NetApp)
- CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N(Red Hat)
- Weakness
- CWE-305
- Fixed releases
- Apache: 11.0.25, 10.1.58, 9.0.121
- Red Hat: 11.0.25, 10.1.58, 9.0.121, tomcat, jws6-tomcat-0:10.1.49-16.redhat_00016.1.el10jws, jws6-tomcat-0:10.1.49-16.redhat_00016.1.el8jws and 7 more in the advisory
- VulniPulse record
- Published · Updated
Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-68569; bulletin-wide values are not repeated here.
Is CVE-2026-68569 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-68569 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-68569?
Upgrade to a fixed release named by the vendor:
- Apache: 11.0.25, 10.1.58, 9.0.121
- Red Hat: 11.0.25, 10.1.58, 9.0.121, tomcat, jws6-tomcat-0:10.1.49-16.redhat_00016.1.el10jws, jws6-tomcat-0:10.1.49-16.redhat_00016.1.el8jws
- Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue. (Apache)
- To mitigate this issue, avoid using CLIENT-CERT or SPNEGO authentication methods with the DataSourceRealm in Apache Tomcat. Alternatively, restrict network access to the Apache Tomcat instance to trusted clients only, thereby limiting exposure to potential attackers. If changes are made to the Tomcat configuration, a service restart may be required for the changes to take effect. (Red Hat)
Vendor advisory comparison
Apache
1 advisory- Advisory severityHigh8.1
High [CVE-2026-68569] Apache Tomcat: Principal lookup can fail open in some cases
CVE-2026-68569Source published Source updated
Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
- Affected products in this advisory
- Apache Tomcat
- Source-reported affected versions
- Apache Tomcat 11.0.0-M1 through 11.0.24
- Apache Tomcat 10.1.0-M1 through 10.1.57
- Apache Tomcat 9.0.0.M1 through 9.0.120
- Apache Tomcat 8.5.0 through 8.5.100
1 more entries in the full advisory.
- Source-reported fixed versions
- 11.0.25
- 10.1.58
- 9.0.121
- Mitigation guidance
- Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
NetApp
1 advisory- Advisory severityHigh8.1
High [CVE-2026-68569] Apache Tomcat Vulnerability in NetApp Products
NTAP-20260902-0016Source published Source updated
Apache Tomcat versions 11.0.0-M1 through 11.0.24, 10.1.0-M1 through 10.1.57, 9.0.0.M1 through 9.0.120, 8.5.0 through 8.5.100 (EOL), and 7.0.0 through 7.0.109 (EOL) are susceptible to a vulnerability which when successfully exploited could lead to disclosure of sensitive information or addition or modification of data. NetApp reports that one or more additional products remain under investigation; review the canonical advisory for current status. NetApp states there is no workaround available at this time.
- Affected products in this advisory
- No product details extracted. Check the source bulletin.
- Source-reported affected versions
- 11.0.0
- 11.0.24
- 10.1.0
- 10.1.57
6 more entries in the full advisory.
- Source-reported fixed versions
- No fixed-version detail extracted. This does not mean no fix exists.
- Mitigation guidance
- No mitigation guidance extracted; consult the source.
Red Hat
1 advisory- Advisory severityHigh8.2
High [CVE-2026-68569] Improper Authentication due to principal lookup failure
CVE-2026-68569Source published Source updated
Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue. This can lead to unauthorized access to the system. This Important vulnerability in Apache Tomcat allows unauthorized access when configured with CLIENT-CERT or SPNEGO…
- Affected products in this advisory
- Red Hat JBoss Web Server 6.2.5
- Red Hat JBoss Web Server 6.2 on RHEL 10
- Red Hat JBoss Web Server 6.2 on RHEL 8
- Red Hat JBoss Web Server 6.2 on RHEL 9
11 more entries in the full advisory.
- Source-reported affected versions
- 11.0.0
- 11.0.24
- 10.1.0
- 10.1.57
6 more entries in the full advisory.
- Source-reported fixed versions
- 11.0.25
- 10.1.58
- 9.0.121
- tomcat
9 more entries in the full advisory.
- Mitigation guidance
- To mitigate this issue, avoid using CLIENT-CERT or SPNEGO authentication methods with the DataSourceRealm in Apache Tomcat. Alternatively, restrict network access to the Apache Tomcat instance to trusted clients only, thereby limiting exposure to potential attackers. If changes are made to the Tomcat configuration, a service restart may be required for the changes to take effect.
More Apache advisories
- CVE-2026-103119Oct 20, 2026Buffer under-read vulnerability in Apache Tomcat meant that a large non-blocking write
- CVE-2026-101356Oct 20, 2026Incorrect object recycling and re-use vulnerability in Apache Tomcat affecting HTTP/2
- CVE-2026-101296Oct 20, 2026missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm
- CVE-2026-93446Oct 20, 2026Apache Tomcat: Possible TLS 1.3 connection failures
- CVE-2026-88041Oct 20, 2026Apache Tomcat: HTTP/2 trailer header cross-contamination
- CVE-2026-80353Oct 20, 2026Apache Tomcat: TOCTOU when setting specific permissions for Unix Domain Sockets - Fix
Follow CVE-2026-68569 in the free weekly digest
Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.
Browse the latest tracked CVEs or the CVEs listed in CISA KEV.
Android app · Google Play
Get alerts for new CVEs on your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.