CVE-2026-84939
Path traversal vulnerability in Apache FreeMarker template loading mechanism, if the attacker can specify an arbitrary malformed locale identifier to FreeMarker, and the localized lookup configuration setting is enabled (it's by default enabled)
CVE-2026-84939: Path traversal vulnerability in Apache FreeMarker template loading mechanism, if the attacker can specify an arbitrary malformed locale…
Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.
Get an email when Apache publishes the next one.
VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
CVE-2026-84939 key facts
- CISA KEV
- Not listed (catalog checked )
- Highest advisory severity
- Critical
- CVSS base score
- 9.1 (Apache), 7.5 (Red Hat)
- Fixed releases
- Apache: 2.3.35
- Red Hat: 2.3.35, org.freemarker/freemarker:2.3.35, RHSA-2026:83082, RHSA-2026:83520
- VulniPulse record
- Published · Updated
Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-84939; bulletin-wide values are not repeated here.
Is CVE-2026-84939 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2026-84939 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2026-84939?
Upgrade to a fixed release named by the vendor:
- Apache: 2.3.35
- Red Hat: 2.3.35, org.freemarker/freemarker:2.3.35, RHSA-2026:83082, RHSA-2026:83520
- Users are recommended to upgrade to version 2.3.35. (Apache)
- To mitigate this vulnerability, disable the localized lookup configuration setting within your Apache FreeMarker deployment. This setting is enabled by default and its deactivation prevents the processing of malformed locale identifiers that could lead to path traversal. Consult your application's documentation for specific instructions on how to configure FreeMarker to disable localized lookup. A restart of the affected application or service will be required for the changes to take effect. Disabling localized lookup may impact applications that rely on this feature for internationalization. (Red Hat)
Vendor advisory comparison
Apache
1 advisory- Advisory severityCritical9.1
Critical [CVE-2026-84939] Path traversal vulnerability in Apache FreeMarker template loading mechanism, if the attacker can specify an arbitrary malformed locale identifier to FreeMarker, and the localized lookup configuration setting is enabled (it's by default enabled)
CVE-2026-84939Source published Source updated
Path traversal vulnerability in Apache FreeMarker template loading mechanism, if the attacker can specify an arbitrary malformed locale identifier to FreeMarker, and the localized lookup configuration setting is enabled (it's by default enabled). This issue affects Apache FreeMarker from 2.2.0 through 2.3.34. Users are recommended to upgrade to version 2.3.35. Disabling localized lookup in previous versions also mitigates this. Note that even in versions affected by this vulnerability, the files that can be loaded remain restricted by the TemplateLoader that FreeMarker is configured to use. In particular, FileTemplateLoader prevents attempts to traverse outside the baseDir specified in its constructor. Other TemplateLoader implementations may allow access outside their designated base…
- Affected products in this advisory
- Apache FreeMarker
- Source-reported affected versions
- 2.2.0 through 2.3.34.
- through 2.3.34
- Source-reported fixed versions
- 2.3.35
- Mitigation guidance
- Users are recommended to upgrade to version 2.3.35.
Red Hat
1 advisory- Advisory severityHigh7.5
High [CVE-2026-84939] Path traversal via malformed locale identifier
CVE-2026-84939Source published Source updated
Path traversal vulnerability in Apache FreeMarker template loading mechanism, if the attacker can specify an arbitrary malformed locale identifier to FreeMarker, and the localized lookup configuration setting is enabled (it's by default enabled). Users are recommended to upgrade to version 2.3.35. Disabling localized lookup in previous versions also mitigates this. Note that even in versions affected by this vulnerability, the files that can be loaded remain restricted by the TemplateLoader that FreeMarker is configured to use. In particular, FileTemplateLoader prevents attempts to traverse outside the baseDir specified in its constructor. Other TemplateLoader implementations may allow access outside their designated base directory, but they are still constrained by the underlying…
- Affected products in this advisory
- Red Hat build of Quarkus 3.27.6.redhat
- Red Hat build of Quarkus 3.33.4.redhat
- Red Hat Single Sign-On 7
- Source-reported affected versions
- 2.2.0
- 2.3.34
- Source-reported fixed versions
- 2.3.35
- org.freemarker/freemarker:2.3.35
- RHSA-2026:83082
- RHSA-2026:83520
- Mitigation guidance
- To mitigate this vulnerability, disable the localized lookup configuration setting within your Apache FreeMarker deployment. This setting is enabled by default and its deactivation prevents the processing of malformed locale identifiers that could lead to path traversal. Consult your application's documentation for specific instructions on how to configure FreeMarker to disable localized lookup. A restart of the affected application or service will be required for the changes to take effect. Disabling localized lookup may impact applications that rely on this feature for internationalization.
More Apache advisories
- CVE-2026-111422Oct 26, 2026Apache Airflow SSH provider command injection
- CVE-2026-115748Oct 26, 2026**UNSUPPORTED WHEN ASSIGNED** Authorization bypass in Apache Vysper, all versions
- CVE-2026-115721Oct 26, 2026**UNSUPPORTED WHEN ASSIGNED** Unbounded allocation in XML parsing in Apache Vysper; all
- CVE-2026-90885Oct 26, 2026Apache Camel Saxon XXE
- CVE-2026-94386Oct 26, 2026Apache Camel Oauth information disclosure
- CVE-2026-110748Oct 26, 2026This issue affects Apache SIS from version 0.7 through 1.6 inclusive
Follow CVE-2026-84939 in the free weekly digest
Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.
Browse the latest tracked CVEs or the CVEs listed in CISA KEV.
Android app · Google Play
Get alerts for new CVEs on your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.