Skip to content
VulniPulse
Advisory severityMedium5.1Apache Software Foundation

Medium [CVE-2026-76984] Improper neutralization of input during web page generation in Apache Wicket

This medium-severity Apache Software Foundation advisory covers CVE-2026-76984 affecting Apache Wicket.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-76984 Source published Source updated

VulniPulse record published Record updated

CVE-2026-76984
Affected products & platforms
Apache Software FoundationUnclassified
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Improper neutralization of input during web page generation in Apache Wicket.

org.apache.wicket.markup.head. MetaDataHeaderItem generates and header tags.

It escaped the attribute names it wrote, but ran the attribute values through a replacement of " with \". A backslash before a double quote means nothing in HTML, so a value containing a double quote ends its own attribute and what follows is parsed as further attributes of the generated tag.

An application is affected where it supplies an attribute value holding data an attacker can influence, through addTagAttribute or the forMetaTag and forLinkTag factory methods. A value may be given as an IModel, so it is not necessarily a literal.

There is no setting to change; an application can only avoid supplying a value that contains a double quote. Note that these values have never been escaped effectively: before the change released in 6.24.0, 7.4.0 and 8.0.0 they were written with no escaping at all.

This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 6.17.0 onwards are also affected.

Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Affected versions
  • 8.0.0 through 8.18.0
  • 9.0.0 through 9.23.0
  • 10.0.0 through 10.10.0.
  • through 10.10.0

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Fixed versions
  • 8.19.0
  • 9.24.0
  • 10.11.0

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.