Skip to content
VulniPulse
Advisory severityMedium6.1Apache Software Foundation

Medium [CVE-2026-76986] Improper neutralization of input during web page generation in Apache Wicket

This medium-severity Apache Software Foundation advisory covers CVE-2026-76986 affecting Apache Wicket.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-76986 Source published Source updated

VulniPulse record published Record updated

CVE-2026-76986
Affected products & platforms
Apache Software FoundationUnclassified
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Improper neutralization of input during web page generation in Apache Wicket.

org.apache.wicket.markup.html.form. AbstractSingleSelectChoice, the base class of DropDownChoice, writes the body of the default option — the entry shown when no choice is selected — into the markup as it is, while every other option body in the same select is escaped according to the escape-model-strings setting.

The body comes from getNullValidDisplayValue() or getNullKeyDisplayValue(), both of which are protected, so what they return is not necessarily the plain text the default implementation reads from a resource bundle.

An application is affected where it overrides one of those methods and returns a value holding data an attacker can influence, or where its own nullValid or null bundle entry holds such a value. The bundles shipped with Wicket contain plain text.

RadioChoice overrides getDefaultChoice to emit no default option and is not affected.

As a workaround, escape the value in the override.

This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.5.0 onwards are also affected.

Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Affected versions
  • 8.0.0 through 8.18.0
  • 9.0.0 through 9.23.0
  • 10.0.0 through 10.10.0.
  • through 10.10.0

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Fixed versions
  • 8.19.0
  • 9.24.0
  • 10.11.0

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Official advisory · high-confidence parse· fetched 2 months ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.