Skip to content
VulniPulse
Advisory severityUnratedApache Software Foundation Updated

Advisory [CVE-2026-83525] Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions

This security Apache Software Foundation advisory covers CVE-2026-83525 affecting Apache Kafka.

Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.

CVE-2026-83525 Source published Source updated

VulniPulse record published Record updated

CVE-2026-83525
Affected products & platforms
Apache Software FoundationMessagingKafka
Open source advisory

Get an email when Apache Software Foundation publishes the next one.

VulniPulse checks Apache Software Foundation's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.

Start your free month

Summary

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2

on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service

(controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic

with no partitions.

Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue.

Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

Affected versions
  • 2.8.0 before 4.2.2
  • 4.3.0 before 4.3.2

Official advisory · medium-confidence parse· fetched 5 hours ago·verify at source

Fixed versions
  • 4.2.2
  • 4.3.2

Official advisory · medium-confidence parse· fetched 5 hours ago·verify at source

Mitigation checklist

Recommended fix / mitigation
  • Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue.
  • Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

Official advisory · medium-confidence parse· fetched 5 hours ago·verify at source

All Apache Software Foundation advisories

Android app · Google Play

Monitor future Apache Software Foundation CVEs from your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Discussion(0)

No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.

Sign in to join the discussion.