High [CVE-2026-83559] Improper encoding or escaping of output in Apache Wicket
This high-severity Apache Software Foundation advisory covers CVE-2026-83559 affecting Apache Wicket.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Apache Software Foundation publishes the next one.
See Apache Software Foundation's last 90 days of advisories first. Then choose the free weekly digest, or a free month of real-time alerts with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).
Summary
Improper encoding or escaping of output in Apache Wicket.
org.apache.wicket.core.util.string. JavaScriptUtils#escapeQuotes() replaces each single quote in its input with a backslash and a single quote, and each double quote with a backslash and a double quote, so that the value can be placed inside a JavaScript string literal.
It does not escape the backslash, which is the character that has to be escaped, and escaped first, for the rest of that escaping to hold. A value that already holds a backslash immediately before a quote therefore ends up with two backslashes in front of that quote: the first escapes the second, the quote itself is left unescaped, and it closes the literal.
Whatever the value carries after that point is no longer text but JavaScript, and it runs in the application's origin and in the session of the user looking at the page.
The method is public, is not deprecated, and its documentation states that its result can be part of a JavaScript call such as an alert; the only limitation it notes concerns JSON values, which need different escaping.
An application is affected wherever it calls the method itself and places the result inside a JavaScript string literal, from its own code or from a component of its own or of a third party, and the value it escapes holds data an attacker can influence.
- 8.0.0 through 8.19.0
- 9.0.0 through 9.24.0
- 10.0.0 through 10.11.0.
- through 10.11.0
Official advisory · high-confidence parse· fetched 9 hours ago·verify at source
- 8.20.0
- 9.25.0
- 10.12.0
Official advisory · high-confidence parse· fetched 9 hours ago·verify at source
Mitigation checklist
- Users of Apache Wicket 7.x or older, which are no longer supported, should upgrade to a supported version.
- Users are recommended to upgrade to version 8.20.0, 9.25.0 or 10.12.0, which fix the issue.
Official advisory · high-confidence parse· fetched 9 hours ago·verify at source
More Apache Software Foundation advisories
- CVE-2026-111089Nov 1, 2026Apache Wicket reads texts from the application's resource bundles — a localized label
- CVE-2026-95863Nov 1, 2026Apache Wicket cross-site scripting (XSS)
- CVE-2026-87718Nov 1, 2026Apache Wicket 10.10.0, 10.11.0 and 9.24.0 do not set the Content-Security-Policy headers
- CVE-2026-84231Nov 1, 2026Apache Wicket cross-site scripting (XSS)
- CVE-2026-84177Nov 1, 2026Incorrect behavior order in Apache Wicket: a file path is validated before the framework
- CVE-2026-84172Nov 1, 2026Files accessible to external parties in Apache Wicket
Android app · Google Play
Monitor future Apache Software Foundation CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.