CVE-2025-54057
CVE-2025-54057 is covered by the Apache CVE-2026-85229 security bulletin. Not in the CISA KEV catalog. Medium advisory severity. 1 advisory from Apache.
Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.
Get an email when Apache publishes the next one.
VulniPulse checks Apache's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
CVE-2025-54057 key facts
- CISA KEV
- Not listed (catalog checked )
- Highest advisory severity
- Medium
- Vendor advisories
- 1 from Apache
- VulniPulse record
- Published · Updated
Is CVE-2025-54057 exploited?
No exploitation is reported in the sources VulniPulse tracks: CVE-2025-54057 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.
How do I fix CVE-2025-54057?
This CVE is tracked through a multi-CVE bulletin, so its fixed releases may differ from the bulletin-wide values below. Check the vendor source.
Vendor advisory comparison
Apache
1 advisory- Advisory severityMedium6.1
Medium [CVE-2025-54057 +1] ** UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI
CVE-2026-85229Source published Source updated
This bulletin covers 2 CVEs. The products, versions, score and guidance below describe the bulletin; check its source for applicability to this specific CVE.
- * UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI. This issue affects Apache SkyWalking UI: from 10.2.0 through 10.4.0. Users are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.
- Affected products in this advisory
- Apache SkyWalking Booster
- Apache SkyWalking UI
- Source-reported affected versions
- 10.2.0 through 10.4.0.
- through 10.4.0
- Source-reported fixed versions
- 1.0.0
- Mitigation guidance
- Users are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.
More Apache advisories
- CVE-2026-114349Oct 28, 2026Apache Kafka: When a broker decodes a compressed record batch, the per-record decoder
- CVE-2026-112375Oct 28, 2026Apache Kafka: authenticated Kafka principal with no authorization grants
- CVE-2026-116593Oct 28, 2026Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint
- CVE-2026-115644Oct 28, 2026Apache Kafka Connect contains an authentication bypass vulnerability affecting the admin
- CVE-2026-111551Oct 28, 2026Apache Kafka: Several Kafka deserialization paths read a size or count field from input
- CVE-2026-111496Oct 28, 2026Apache Kafka: Kafka Streams derives its stream-time clock from record timestamps
Follow CVE-2025-54057 in the free weekly digest
Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.
Browse the latest tracked CVEs or the CVEs listed in CISA KEV.
Android app · Google Play
Monitor future Apache CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.